I am trying to instal .Net 3.5 framework on windows 10.

First of all I tried installer from https://www.microsoft.com Unfortunatelly it asked me to install .Net before I will install .Net

Then I tried to enable it via Control Panel, but it did not work.

Finally I tried command:

Dism /online /enable-feature /featurename:NetFx3 /All /Source:X:\sources\sxs /LimitAccess

Where X is source drive for my Windows disc. On my terminal I can see:

Deployment Image Servicing and Management
Version: XXX
Image Version: XXX

But then nothing, "Enabling Feature(s)" does not appear.

What is going on?

When I check the logs, each time I try to run this command, it DISM.exe stops doing antyhing on:

DISM   DISM Package Manager: PID=12232 TID=11768 CBS session options=0x20100! - CDISMPackageManager::Internal_Finalize
  • Windows 10 by default already has 4.6.2....You are using, a current version of the Windows 10 ISO, right? What build of Windows 10 are you using? Edit your question to include this information. – Ramhound Jan 10 '17 at 13:17
  • 1
    Possible duplicate of Can't install .net 3.5 on Windows 10 – Ramhound Jan 10 '17 at 13:17
  • Another possible duplicate: Win10 Unable to install .NET Framework 3.5 – Ramhound Jan 10 '17 at 13:18
  • share the log files – magicandre1981 Jan 10 '17 at 16:24
  • It might be possible, it's not actually frozed, but just taking extremely long. I've seen tests here, where (even with /L:4) it was bumbling on that log entry line you mention for 15(!) to 30(!!) minutes, and then just completing successfully after 1 more minute. (So: could "hang" on 10% for 15 minutes, then complete with success 11-100% in the 16th minute) – Martin Dec 4 '17 at 8:06

I encountered this error while using DISM to install some optional features. The reason it was stuck for me were pending installations of "French (France) typing" and "French (France) optical character recognition" optional features. After stopping them DISM successfully installed features.

EDIT: To stop the pending installation I opened Task Scheduler and disabled Microsoft > Windows > LanguageComponentsInstaller > Installation as stated by KMSYP in this post "https://answers.microsoft.com/en-us/windows/forum/windows_10-update-winpc/optional-language-features-fail-to-install/cd2494a9-2311-4e28-99a0-7de390826e45". After this a restart stopped the installations and they have not started yet. I could not manually install .cab files because my problem was on a Windows Server 2016 Version 1607 machine and I haven't found any language packs for it(Windows 10 Version 1607 language packs are not compatible).

  • 1
    Please explain how you stopped them. – djsmiley2k Mar 29 '18 at 12:19

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.