0

So I ran into a perplexing issue with Windows after a plain old reboot. When I boot I get a BSOD saying inaccessible boot device.

Some background on the issue, I have a desktop with 1 SSD containing my Windows install and then I have another traditional hard drive for storing games and anything that takes a lot of space, note that this drive is not bootable. Pretty vanilla setup and it has been working fine for ages so fast forward to a reboot the other day, I don't remember doing anything strange however it is possible as I am a developer and I don't reset my PC very often.

After this reboot I am left with the error "Inaccessible boot device", my first port of call was to run startup repair which reported no error and effectively did nothing but spend some time.

Now where things get interesting, as it turns out I can boot Windows if the SSD is the only drive attached. This means that when my bulk storage hard drive is removed from the system everything works great as Windows isn't trying to boot the non bootable hard drive, you can use any other internal drive and it produces the same result. So my next thought was the boot priority is broken in the windows boot manager however as I can only get to the easybcd edit window with one drive attached the boot order is always correct as there is only one entry. So the real question is how can I "repair" the boot loader priority with only 1 drive in the list.

Some extra bonus info, I am using the UEFI boot loader which I installed fresh over the existing one to reset any settings and it didn't seem to help.

Also as I'm sure somebody will comment, the bios is loading the correct hard drive and windows gives you the little spinning loading symbol (next to the ASUS logo due to UEFI) with the extra drive attached or not and where you would usually get the boot menu is when you get the BSOD. Finally I tried to enable the boot menu so I could force it but no matter what I did it wouldn't appear.

0

A silly solution to a silly problem that surprisingly works. I am posting this in case somebody else runs across the issue. All you have to do is swap the SATA ports around as this resets and drive ID's that windows is using, for myself I moved the hard drive and SSD to previously unused SATA ports. This approach only works on a desktop as you need access to the SATA connectors. I discovered this after reassembling my PC (was cleaning the dust out). I swapped the SATA connectors around by sheer chance as I could make the wiring neater. While I am pretty confident that is the only hardware change if this doesn't work for you then it's most likely because I changed something else and didn't realise. If you have evidence that that is the case then please comment to stop others wasting time. Regardless it's an easy enough fix to try so give it a go.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.