8

Windows 10 Settings includes an option:

When i snap a window, automatically size it to fill available space

(under System - Multitasking)

I don't see any change between when it's enabled or disabled. What does it do?

  • 1
    This question was discussed on meta and was undeleted by three 10K+ users' votes. If you'd like to be dissociated from it, use the "contact us" link in the footer to request its anonymization. – Ben N Jan 11 '17 at 16:06
11

UPDATE: More learned in comments.

The specific setting When i snap a window, automatically size it to fill available space controls the behavior of a window that is snapping into a space where there are already other snapped windows.

If this setting is enabled, when you have snapped one window into an available space and then resized that window, snapping a new window will fill all of the space left over.

If this setting is disabled, when you have snapped and resized one window, subsequent windows will snap to their default half or quarter size and will either overlap existing snapped windows, or "underlap" and leave a gap.

You can test and observe this behavior using the following steps:

  1. Make sure the setting is Enabled, then snap a window to half-screen by dragging it to the right or left edge of the screen and releasing.
  2. Resize this snapped window to make it narrower.
  3. Snap a second window to the other side of the screen and observe that it has filled MORE than half of the screen in order to fully fill the available space.
  4. Now "unsnap" both windows.
  5. Change the setting to Disabled and snap a window to half-screen again.
  6. Resize the window to make it narrower.
  7. Snap a second window to the other side of the screen an observe that it has only filled exactly half of the screen and there is now a gap left over between the two snapped windows.

Original answer:

Windows 10 supports the following snap actions with windows:

  • Drag the window to the top of your screen to maximize it.
  • Drag the window to the left or right edge of your screen (or a border between screens) and it will expand to fill that half of the screen.
  • Drag the window into one of the corners of your screen and it will fill a quarter of the screen.

Note: When dragging the window, the snap action does not initiate until the mouse cursor that is dragging the window enters the interaction zone. So, if you click in roughly the middle of the window's title bar and drag it off to the right edge of your screen, it will not Snap until half the window is off of the edge of the screen and your mouse cursor actually hits the edge of the screen.

There is also a visual cue regarding what will happen if you release the mouse in a given location in the form of a shadow box showing the shape and size the window will Snap to if it is released there.

Try dragging a window around the periphery of your screen and observe how this shadow box changes shape depending on whether your mouse cursor is in a corner, on the left or right edge of the screen, or against the top of the screen.

I've found this to be a rather handy feature, personally. Especially if you're used to maximizing your windows, this can make it quite easy to get used to having more than one program up front and visible on your screen at the same time.

It is also based on touch gestures. If you have a touch screen, you can perform the same window arrangement using your finger to drag the program window up against the top or sides or corners to arrange them.

  • Do you mean to tell me that when you turn off the option I mentioned, snap is disabled on your computer? – ispiro Jan 10 '17 at 18:49
  • You didn't specify what doesn't change. Do the windows snap whether you've got that enable or not, or do they not snap no matter the setting? – music2myear Jan 10 '17 at 18:52
  • But if it does, on your computer, then what does the option right above it - the "Arrange windows automatically...." option do on your computer? – ispiro Jan 10 '17 at 18:52
  • Nothing changes. It all depends on whether I have the option above it on or off. – ispiro Jan 10 '17 at 18:53
  • Try this: Disable that "automatically fill" setting, then snap a window to half the screen. Now resize that window a little bit so it is narrower. Snap another window to the other half of the screen and observe the gap (or overlap). Now enable the setting and try the same steps again. – music2myear Jan 10 '17 at 18:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.