6

Error message: There were some problems installing updates, but we'll try again later. If you keep seeing this and want to search the web or contact support for information, this may help: (0x8024402f)

  1. It is a fresh install (the very first operation after first login was a Update and it failed)

  2. Microsoft Tech Support had remote access to my machine and tried everything (including Windows Update Troubleshooting and other tools). They reinstalled Windows and the problem persisted (then, I erased the HD with diskpart --> clean and reinstalled Windows from scratch, using a new MSDN ISO download)

  3. I've manually installed the january 2017 cumulative patch (KB3213986) and installed (actual version: 1607 (OS Build 14393.693))

  4. Tried every alternative (as delete the SoftwareDistribution folder, running some .bat with re-registration of some DLLs with regsvr32, winsocks reset, etc.)

  5. There are no virus (already tested with Clam Anti Virus Portable, just to be sure)

  6. No firewalls whatsoever (my machine is set to DMZ on internet router). Everything works just fine, except Windows Update.

  7. Time and date are correct, using Microsoft's NTP server

  8. I'm using Google DNS servers (8.8.8.8 e 8.8.4.4), with or without them, same error

  9. I was a Windows Insider, but not anymore

I don't know what else I can do (except to wait for a Visual Studio for Linux and throw Windows in the trash) =\

Can anyone help me? =(

UPDATE: I've plugged in an old Wireless USB Adapter and, using Tethering on an Android with my 4G data, the update works normally.

So, the real question is: what is wrong with my normal internet connection that is preventing me from updating? What can I complain about with my ISP?

  • Can you make the following file available: C:\WINDOWS\Logs\CBS\CBS.log I guess it might be worth renaming the existing one, then force a retry. I assume it creates a new file with just the last attempt. – HelpingHand Jan 11 '17 at 0:53
  • Temporary solution: edit HOSTS file to make fe1.update.microsoft.com.akadns.net point to 134.170.115.62 (originally Google DNS resolves to 65.55.194.221) – JCKödel Jan 11 '17 at 1:56
  • Does following the steps here help: tweaking.com/forums/index.php?topic=1864.0 – HelpingHand Jan 11 '17 at 1:58
  • Have you had this problem always or just recently. Your solution seems odd if you still had the problem even if you were not using google dns – Ramhound Jan 11 '17 at 4:17
2

Error 0x8024402F means WU_E_PT_ECP_SUCCEEDED_WITH_ERRORS:

// MessageId: WU_E_PT_ECP_SUCCEEDED_WITH_ERRORS
//
// MessageText:
//
// External cab file processing completed with some errors.
// #define WU_E_PT_ECP_SUCCEEDED_WITH_ERRORS _HRESULT_TYPEDEF_(0x8024402FL)

Stop the Windows Update service, delete the content of the folder C:\Windows\SoftwareDistribution\Download. Also exclude this folder from your Anti Virus suite.

Now try again to update Windows 10.

  • As I said in 4) and 5), it is useless. – JCKödel Jan 11 '17 at 17:54
  • I have no idea why your ISP corrupts the CABs. Normally my steps fix the issue because they happen mostly only on client side. – magicandre1981 Jan 12 '17 at 21:30
2
>what is wrong with my normal internet connection that is preventing me from updating?

Your ISP (or someone upstream) surely is caching MS updates (in order to avoid downloading million times the same file) and some of them got corrupted...

1

I don't know what the exact cause is, but the following is a possible workaround: click on Advanced Options under Windows Update and deselect "Give me updates for other Microsoft products when I update Windows."

1

If it appears your ISP is caching updates and possibly causing this problem, one solution would be to use a VPN connection to download the updates.

While I cannot suggest a VPN option, careful Google research should indicate trustworthy ones to use which would offer a free trial period or allow you to pay for only one month of service which should be less than $10 USD.

Using a VPN would bypass your ISP and their caching entirely, allowing you to get a good copy of the update files.

If the issue persists even after using a VPN, then it would not be the fault of the ISP.

0

I understand in the original question that the OP's computer is in a DMZ and that the firewall should not be the issue. However, my source of this chronic problem was a Cisco SMB router's firewall setting for blocking/filtering ActiveX controls. Simply disabling that feature resolved the issue.

  • Windows 10 won't use ActiveX anymore for Windows Update. – JCKödel Jun 3 '17 at 15:28
  • 1
    Nevertheless, the Cisco SMB router/firewall setting labeled (by Cisco) as blocking "ActiveX" was the direct cause of my 0x8024402f error in Win10. I can reproduce this at will by changing that one setting on the router. – William Price Jun 3 '17 at 19:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.