22

I use Windows 10 at work, and for security reasons, I always lock my workstation when I leave the room for any reason. The problem is that my monitor is a Samsung 4K TV and the lock screen puts it to sleep after only 60 seconds, and after a few more minutes, it goes completely off, requiring me to use the remote control to turn it on again. I'm OK with using the remote to turn it on in the morning when I come in, but it's annoying to have to use it after a 10-15 minute conversation in another office.

27

After several unsuccessful searches and attempts to fix the problem using standard and advanced settings, I finally came across a registry key setting that seems to be required to allow changes to the timeout on the lock screen that puts the screen to sleep after 1 minute.

In case that web site goes away, the key is:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\7516b95f-f776-4464-8c53-06167f40cc99\8EC4B3A5-6868-48c2-BE75-4F3044BE88A7]
"Attributes"=dword:00000002

If the value is 1, the UI to alter this setting will not show up in the advanced power settings. If it is 2, the UI will show up. Reportedly, if it is zero, the monitors will never turn off but neither I nor the guy who posted the linked solution has tested that.

enter image description here

  • 3
    Awesome, as this is extremely annoying behaviour. I have multiple thunderbolt screens and they move Windows around after the system wakes up. One of my colleagues had a similar problem as his Bluetooth mouse doesn't wake after sleep. At least we can now lock our screens and walk away without the extra hassle when we get back. – Jeroen Ritmeijer May 3 '17 at 11:59
5

The above answer prevents the screen from going black, but preventing the system from sleeping is a different thing. There is another registry entry to prevent falling asleep.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\7bc4a2f9-d8fc-4469-b07b-33eb785aaca0

Set the value to 2 and under advanced power settings you now get Sleep → System unattended sleep timeout, where you can set the value to 0 minutes. Rebooting your system to view the new option is not required.

  • Is rebooting required for the option to take effect? I tried changing and it didn’t make a difference but I don’t want to have to bother to reboot if I don’t have to. – binki Mar 19 at 18:33

protected by Community Oct 31 '18 at 5:14

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.