How do you clear cached redirects in Chrome?

I changed the DNS for a domain name and when I go to mydomain.com. Even though ping mydomain.com now shows it resolves to the correct IP, if I type in "mydomain.com" into Chrome, it still redirects to mydomain.com/404, which was a redirect automatically setup by the old webhost.

Clearing Chrome's browser cache has no effect, and Chrome seems to ignore /etc/hosts. I tried using a "different" URL, like mydomain.com?123, but Chrome still redirects to mydomain.com/404. Is this a bug or is there someway to clear whatever cache Chrome uses to save 301 redirects?

On desktop Chrome, deleting the last hour of browsing history works, so long as you've followed the redirect within the last hour.

On Android Chrome, visit chrome://net-internals, click the downward arrow at the top right corner, and choose 'clear cache'. That is the only solution I found for Chrome on Android.

  • 2
    On desktop - chrome://net-internals approach does work also. – Francis Martens Apr 18 at 8:08
  • 1
    In OS X when modifying hosts file Chrome just keeps redirecting despite clearing everything; even thought chrome://net-internals. It even redirects when using private browsing tabs, so it is probably not your regular cache issue... Any ideas? – LyK May 8 at 22:57
  • Seems to be a known Chrome issue. Some solutions are presented here: superuser.com/questions/648133/… – LyK May 8 at 23:13

I had a similar issue with a site still re-directing to my.site.com/new-site and found the 'clear cache' via internals to work.

Redirects can be caused by a variety of things - caching by your browser, your system, the network, the site configuration itself and any in between steps.

In addition to clearing browsing history and cookies, I also tried the answers from Clear cache for specific domain name in chrome - I suggest trying answers in order of increasing complexity (e.g. start with what you're happiest with and if that doesn't work, try one of the more tricky solutions)

From https://superuser.com/users/83619/tom-auger

After opening up the developer tools (usually by pressing F12) Click + Hold on the "Reload Page" button. From the popup list, choose "Empty Cache and Hard Reload".

From https://superuser.com/users/87608/euroblaze

Here's how to delete Chrome's cookies selectively by domain or subdomain:
* go to chrome://settings/content/cookies
* type the domain name in the search box
* click delete

  • 1
    +1 My issue was that http : //127.0.0.1:8000 was redirecting to https : //127.0.0.1:8000 which is obviously not what I wanted. I tried everything from deleting cookies to checking out chrome://net-internals but it didn't seem to work for me. What did work for me was bringing up the chrome dev tools, click+hold an then "Empty Cache and Hard Reload". – Akshay Gaur Jul 19 at 14:33

If it's an 301 redirect Chrome will cache it. To clear the cache, go to:

Chrome Menu > Settings > Show advanced settings... > Privacy > Click Clear browsing data...

Good luck.

  • which part shall one thick for the redirects? – João Pimentel Ferreira Apr 4 '17 at 19:30
  • And I've cleared my browser history and it didn't solve the issue, The link from search results pointed me to this comment, use most up voted answer instead that works just fine. – jcubic Jun 24 at 11:49

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.