1

I have several USB thumbdrives of various brands. We use Microsoft BitLocker Administration and Monitoring (MBAM) and Bitlocker to encrypt the thumb drives.

I will take a brand new thumb drive, plug it into my machine. It mounts as the D drive, and I am able to copy files to it. I then enable bitlocker on the drive and encrypt the entire drive. Once the encryption is complete, I am still able to read the drive and put files on it. I properly eject the drive, plug it back in, it prompts for a password, as expected, I put in the correct password and the drive unlocks.

The drive icon in Windows explorer changes from the locked icon to the unlocked icon. I then go to open the drive, and it says “Please insert disk into USB Drive”.

I then go into disk management and change the drive letter from D to F, and it works. I am able to get into the drive with no problems. I then properly eject the drive, plug it back in, put in the password, it unlocks, I go to open the drive and it says “Please insert disk into USB Drive” I change the drive letter back from F to D, and then Im able to open the drive.

Ive tried this with five different thumb drives, and five different PCs. This seems to only be happening on Windows 8.1 and 10. My Windows 7 machine works fine.

Has anyone seen this before? Could there have been a recent update that caused this to happen?

I know the drive is not bad and the data is intact. I dont need a drive recovery program. It seems like when bitlocker unlocks the drive, it just doesnt associate it with the drive letter.

0

I know this question is old, however, I ran into the same problem recently on Windows 10 Fast build.

In short, you need to modify the AutoPlay settings to "Ask me every time" or "Take no action". For me once changed, I still get the normal Windows 10 pop-up message to click and unlock the drive. If you choose "Configure storage settings (Settings) you can a different error "The directory name is invalid"; at least for me, I do.

How to access the AutoPlay settings. There is a multitude of ways.

Via Control Panel:

  • Option one:

    1. Click on Start
    2. Scroll to the W section of the App list and click on Windows System; it will expand.
    3. Click on Control Panel
    4. Click on Hardware and Sound then AutoPlay.
    5. In the drop-down window to the right of "Removeable drives" change to "Ask me every time" then click on save.
  • Option two:

    1. Click on Start then start typing the phrase "Control Panel" (without the quotes) and click on "Control Panel" when you see it listed.
    2. Click on Hardware and Sound then AutoPlay.
    3. In the drop-down window to the right of "Removeable drives" change to "Ask me every time" then click on save.

Via Windows Settings:

  1. Click on Start
  2. Click on Settings (identifiable by the Gear icon bottom left of the start menu).
  3. Click on Devices then AutoPlay on the left side panel.
  4. In the drop-down window under "Removeable drive" change to "Ask me every time" then click on save.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.