2

I've been trying to install Plex Media Server following this guide.

When I source /etc/default/plexmediaserver then:

start-stop-daemon --start -c $PLEX_MEDIA_SERVER_USER --exec /usr/sbin/start_pms

(manually doing the steps the service file /etc/init/plexmediaserver.conf defines) I get:

6 3000 /var/lib/plexmediaserver/Library/Application Support
8192
Error: Unable to set up server: bind: Cannot assign requested address (N5boost16exception_detail10clone_implINS0_19error_info_injectorINS_6system12system_errorEEEEE)

This problem persists through a reboot. The logs in /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Logs look clean, besides also reporting the same cryptic error. The Crash Reports folder contains an empty folder structure.

I have reconfigured the package following the uninstallation instructions:

dpkg -r plexmediaserver
rm -rf /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/

Then reinstalled:

sudo apt-get install -t jessie plexmediaserver

I had gotten Plex working previously, then this problem appeared and I reimaged the entire OS and tried again on a fresh install. This time, the server worked for a few minutes before a reboot then couldn't come back.

I'm really frustrated and would appreciate any help! Thanks!

3

Had the same issue after disabling ipv6 on my RPi 3. You have probably disabled ipv6 on your pi and Plex is trying to bind to it.

Go to:

/var/lib/plexmediaserver/Library/Application\ Support/Plex\ Media\ Server/Preferences.xml

Then Change EnableIPv6="1" to EnableIPv6="0"

Restart your plex service and everything should be up and running.

  • I ran into this issue when I switched from running Plex in Docker to using Docker Compose. This fixed it. – etherous Aug 25 '18 at 18:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.