0

(Possibly sometime) after upgrading to Win 10, my HP DV5-2144ca Laptop became sluggish. Slow browsing experience, YouTube video lagging...

In TaskManager I've noticed that CPU speed is limited to 0.8 GHz and CPU utilization tops around 33%.

Laptop is connected to AC 99% of the time

After a fresh restart (ON/OFF) everything works fine (speed fluctuates between 0.77 to 2.40 GHz) , then for no apparent reason CPU slows down to 0.8 GHz.

I've run Open Hardware Monitor the CPU temps seems OK around 55 to 65 oC

  • I tried "high performance" power option
  • I even put the laptop in the fridge :-) before turning it on. But the problem reappears even with CPU temp near 35 oC
  • There is no BIOS option for turning AMD POWERNOW! off.

I don't expect any help from HP tech, since this is a 6 years old Laptop. I don't want to buy another computer. This one works fine (when CPU speed is not limited).

Is there a solution ?

Snapshot After a fresh startup, everything OK: Snapshot After a fresh startup, everything OK Later another snapshot when YouToube video playing and lagging. Later another snapshot when YouToube video playing and lagging

EDIT

I was going to rant but found this post that summarizes everything I wanted to say.

  • These comments seem to be interesting, no? – Run CMD Jan 13 '17 at 3:18
  • This is a feature , not a bug. Your CPU reduce its speed when nothing to do and boost it to maximum when their is an actual job. This feature keep your computer cool and when you are on battery you will get more hours on it. If you really think that it is wrong, go to control panel->Power options and change power plan to high performance or change power plan in advanced settings in processor section and set minimum and maximum to 100%. – Alex Jan 13 '17 at 6:00
  • When you playing youtube video, you browser probably using hardware accelerated processing (read use GPU, not CPU) that is why you cant see 100% on your CPU. Try to disable hardware acceleration (in firefox it here: about:preferences#advanced) . Another issue could be with your internet connection(not wireless, but ISP), if somebody use it in the same time as you are. Try to reduce quality of youtube video, by clicking on gear icon and reduce quality from HD to say 480 and check if it improved – Alex Jan 13 '17 at 6:04
  • @ClassStacker I tried the suggestions . Booted with Linux mint and got contradicting CPU speed reports from cpuinfo lscpu and dmidecode. Also tried min 99% & max 99% in "high performance" power management profile. nothing worked. – Farsee Jan 13 '17 at 21:45
  • @Alex ISP is not an issue (no wireless, only user on the LAN + 30/10Mb Internet). Removed the battery to be sure that battery profile is not used. Tried Firefox without Hdw acceleration with no difference in performance. Chrome performs slightly better on Video. But everything else Excel, Word etc become slow when CPU is limited to 0.8GHz. – Farsee Jan 13 '17 at 21:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.