0

I am trying to recover data for a friend. I have cloned their drive and ddrescue reported no errors.

When I try to access the destination drive I can access it, it reports 200 GB free space of 2 TB so I know there is something on it but I can't see any of the files. I think that ddrescue got all the files but not the filesystem. I was using ddrescue in Linux Parted Magic.

The command I used was:

ddrescue /dev/sda /dev/sdc /media/sdh2/log/log.log

The log file also reported no errors.

  • Could you tell, when you cloned original drive, how it was mounted? I mean - had that drive write permission? – Alex Jan 13 '17 at 16:24
  • I'm not actually sure I just ran the command and it worked.it failed the 1st couple of times till I got the correct path for the usbstick for the logfile .But then it just worked and it has definatly cloned stuff from damaged drive to new drive I can open the drive I just cant see the files but the drive is reporting 1.6tb used. – Simon Jan 13 '17 at 16:40
  • Any chance that it's a permissions issue? Did you try accessing the files using the owner's userid? – fixer1234 Jan 14 '17 at 5:00
  • The reason I asked you about mounting is what I learned hard way once. Read carefully this. – Alex Jan 14 '17 at 5:05
0

Good news I think I've got the whole drive back .I removed the clone from my parted magic linux system put it on a windows 10 system ran chkdsk driveletter: /f /x which rebuilt the file system /f finds errors /x forces drive dismount . If I find any files that wont open I will run chkdsk driveletter: /f /r /x adding the /r which locates and recovers bad sectors.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.