6

I have a 200 MB Western Digital 2.5" IDE drive, originally from an Amiga 1200, that I would like to try to get an image file of, so I can keep the data that is on it.

Since the drive is very old, and has been sitting in an attic for 20 years, I want to avoid powering it up unless I have to, it might fail at any time.

My first attempt was to buy an external USB hard drive enclosure (specifically this one https://www.amazon.co.uk/gp/product/B002UZRRXG/ref=oh_aui_detailpage_o02_s00?ie=UTF8&psc=1).

The drive spun up when connected to USB and Windows correctly identified the drive as a Western digital drive, but all the imaging tools I tried showed the drive size as 2.2 TB, not 200 MB. They also reported errors when trying to image the drive. I also tried directly mounting the drive in WinUAE (an Amiga emulator which supports reading data directly from physical Amiga hard drives) to create an image file, but the drive showed as "ACCESS DENIED" when running as a regular user and didn't show up at all in WinUAE when running as an administrator.

I then tried booting into Linux (drive spun up again!) and simply doing

dd if=/dev/sd<X> of=/path/to/img/file bs=512

But then I just got lots of input/output errors when reading from /dev/sd. Linux didn't get the name and manufacturer correct, but still showed the drive as being much larger than 200 MB.

I suspect that the firmware in the enclosure cannot handle the old drive and this is the cause of these issues.

Next I'll attempt a cheap IDE-SATA converter and connect it as an internal SATA socket and see if that works better. Are there any other options or maybe known good converters I could use?

I don't have a computer from the mid nineties, otherwise connecting to that would probably work.

Is there somewhere I can manually enter the number of cylinders and heads and override the bad size reported by the enclosure?

  • 2
    If you know the exact hardware details of the drive (sectors, etc.), you might be able to use hdparm, but it's also possible the drive is just bad .. Just because it spins up doesn't mean the firmware/hardware are fully functional; if it's been sitting in the attic for 20 years, there's a good chance that any sort of atmospheric or normal EMI, or things like dust, moisture, or heat, could cause it to have bit-rot .. Is there 23 year old data on there that is that important? – txtechhelp Jan 14 '17 at 1:37
  • I do have information on the drive geometry (it's printed on a sticker on the drive) but after reading the man page of hdparm I can't find a way to alter the kernels idea of how many sectors there are. How would I accomplish that?The data on the drive isn't irreplacable but it contains some of the first programs I ever wrote and it would be nice if I could retrieve them. – Joakim Hårsman Jan 14 '17 at 23:09
  • 1
    "I want to avoid powering it up unless I have to" -- The HDD has to be powered up and spinning if you expect to do anything. You need to ensure that the HDD is getting enough power; an external power supply would be ideal. Old laptop SATA drives exceed the 500mA capacity of a single USB port; an older IDE should be much worse. FYI today I tested an IDE HDD manufactured in 1996 with my USB-to-IDE/SATA adapter, and had no issues reading it. – sawdust Jan 14 '17 at 23:45
  • I tested a Conner CP-344 IDE HDD manufactured in 1989 with my USB-to-IDE/SATA adapter, and had serious issues reading it. It was recognized as a "Conner", but capacity was 2TB instead of just 42MB. On an old Dell Dimension 3000 PC, this HDD is correctly identified and R/W capable. I suspect that my USB adapter only supports EIDE (1994) or ATA-2 (1996). – sawdust Jan 15 '17 at 1:47
  • 1
    You might have some luck over on Retrocomputing. – a CVn Jun 16 '17 at 20:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.