7

I have an Xbox One Elite controller and today I noticed moving the stick scrolls in default windows apps. I have no apps installed that would allow this behavior (xpadder, joy2key, gopher, etc). I am in the "Release Preview" channel of the insider program so I'm not sure if this was a new update or what.

I'm afraid it's causing issues with Steam so I want to figure out how to disable this behavior.

14

Turns out it was the new Steam "Xbox Configuration Support" feature. I disabled it and now the controller doesn't do anything in Windows and all my games work again.

Before (with Issue):

enter image description here

After (Without Issue):

enter image description here

  • Damn Steam was driving me crazy.. one out of 5+ problems fixed thanks! Now just have to figure out the conflict problem with 2 controllers haha – NaturalBornCamper May 24 '17 at 16:59
  • my controller doesn't work at all now. – Alexej Magura Dec 14 '17 at 1:19
  • thank you. go to hell big picture mode. – stackers Nov 2 '19 at 20:51
  • 1
    The fucking right answer, thanks bro. – Jim Chen Nov 6 '19 at 12:43
0

If you want to keep Steam's "XBox configuration support" enabled (which is useful for things like calibrating dead zones + some games require it) and still disable the controllers from controlling your mouse and keyboard:

  1. From the steam main application (not Big Picture) click "Steam" in the upper left corner
  2. Click "settings"
  3. Click the "controller" tab
  4. Click Desktop Configuration
  5. Select each of the fields that say for example "Mouse button 1" or "Left ctrl" and use your xbox controller to press the button for "remove" (I had some issues using the mouse in this menu). Some fields have sub-fields and you need to remove those too.
  6. Press the back button (default: (B) ) on your controller until you exit the special menu.
  7. You're all done :)

Not the answer you're looking for? Browse other questions tagged or ask your own question.