3

I have installed OpenMediaVault 3.0.59 on my Rpi3. I'm trying to use it as a NAS for my other Windows 10 PC. But even after enabling the SMB/CIFS, it does not shows up in the network of the Windows 10 PC but shows up perfectly in another Win 7 PC and a android device?

  • @ITSolutions try that. still can't access it. – Lokesh Sah Jan 15 '17 at 7:12
  • Does Windows 10 PC is able to see other share on your network? Try also to access NAS by IP (\\ip.ip.ip.ip\share) instead of name. Check W10, may it pick "public" network profile that will prevent to browse local network – Alex Jan 25 '17 at 5:59
0

Windows 10 has disabled guest access to remote file shares for security reasons:

While the server may be fine not distinguishing among clients for files [...], this can actually put you at risk elsewhere. Without an account and password, the client doesn't end up with a secure connection to the server. A malicious server can put itself in the middle (also known as the Man-In-The-Middle attack), and trick the client into sending files or accepting malicious data.

The safe solution is to add an account to your NAS and use it to access the share.

The unsafe solution is to edit the registry. You need to create a DWORD parameter named

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters\AllowInsecureGuestAuth

and set it to 1.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.