0

I'm having trouble communicating between devices spread across two routers (i.e. Apple TV to share folders and Apple TV to iTunes home sharing from PC) Hoping someone can help me. I have 2 routers within my home network. It looks like this:

Router 1 (main): This router has its' WAN port connected to my ISP provider's modem. This router's LAN/wireless network is configured as 192.168.1.0/24 with router IP address set to 192.168.1.1. Router 2 (Secondary): this router is connected by ethernet cable from its' WAN/internet port to port 1 on router 1. It has the IP address set to 192.168.1.100. Router 2's LAN network is configured as 192.168.2.0/24 with the router IP address being 192.168.2.1.

I have a few devices connected to both routers, mostly wireless, with a few wired.

I have server 1 connected to router 1 via wifi. It has an IP of 192.168.1.101. This machine is hosting my itunes media library through home sharing, and has several share folders filled with media.

I have an ATV behind router 2 connected via DHCP, usually sitting at 192.168.2.120

I have setup a static route on router 1, setting the network address of 192.168.2.0 255.255.255.0 to point to 192.168.1.100.

I am able to ping from computers connected to router 1 to computers connected to router 2 and vice versa no problem (because of the static route I set explained in the previous paragraph - prior to this static route setting, I could only ping from devices on router 2 to devices on router 1 and not vice versa).

I am trying to use ATV's home sharing to stream my music collection from my server and I'm also trying to use the VLC app to play my media from my share folders which are on server 1.

Home Sharing on the ATV (which is connected to router 2) does not see the itunes computer on my network (I'm assuming because it's on a different subnet). If I connect my ATV to router 1, it works fine.

VLC player, when opened, and displaying Local network, no servers/share folders come up. If I connect ATV to router 1, then they appear and it works. Again, same issue as above.

So my question is, how can I somehow get these services to display over the two routers so that my ATV can sit connected to router 2, but can see the home sharing itunes and the share folders from the server connected to router 1?

1

The solution is to configure Router 2 to be just an AP, not a router, so that your whole home LAN is one big subnet served by Router 1.

To do this, connect the Ethernet from Router 1 to one of Router 2's LAN ports, not its WAN port. Turn off Router 2's DHCP Server. Give it a LAN IP address on the 192.168.1.x/24 subnet. If you've manually configured any devices with static IP addresses on the old 192.168.2.x subnet, you'll want to reconfigure them for DHCP or for a static IP address on the 192.168.1.x subnet.

Without that second router (really, NAT gateway) getting in the way, everything will be able to easily see and connect to everything else, without setting routes or port forwarding rules.

  • thanks for the post, however I'm aware this would solve the problem. But I do NOT want to make router 2 an AP. I need/want to keep these two networks separate, which is why I asked how I can work around the issue. So basically, given that I can't/won't change router 2 to an AP, how is what I asked above possible. Is it not? – AmericanNinja Jan 21 '17 at 7:19
  • @AmericanNinja Please edit your question to explain in what ways you want to keep the two networks separate ( what protocols/activities you want to block between sides of the network) and in what ways you want them to work (if anything other than this ATV case). Even without bridging, making discovery and connectivity work across a network tends to make everything work, so we'd need to know what your separation requirements are before we could help you. – Spiff Jan 21 '17 at 17:07
  • @AmericanNinja Also, can you proof-read your question? I think you meant to write "Router 1" in two different places where you actually wrote "Router 2". – Spiff Jan 21 '17 at 17:09
  • I have updated the post. Thank you Spiff! Sorry, I wrote it half brain dead during the early morning hours after becoming completely exhausted from trying to figure it out. You were correct, towards the end of the explanation, I referenced Router 2 two times, when I should have said router 1. I went ahead and cleaned up a few other things just to make it more clear. Hopefully it is now. Thank you! – AmericanNinja Jan 23 '17 at 13:02

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.