1

I get the following error whenever I try to turn my mobile hotspot on.

enter image description here

I made sure the following things, that usually come up when googled, are right:

  1. My Wi-Fi is on and I'm connected to my home network and have access to internet.
  2. My Wi-Fi card supports hostednetwork feature.

enter image description here

  1. Internet Connection Sharing (ICS) and Routing and Remote Access services are running and are NOT disabled. (Tried turning them automatic too)
  2. No Warning symbols in Device Manager. My network card is working properly and has latest drivers installed.
  3. I'm still able to create a hostednetwork successfully using netsh wlan start hostednetwork without any errors.
  4. Restarted several times, reinstalled the drivers, and ran the troubleshooters many times, but none of them seemed to change anything.

Note: When I try (5) there's no internet when connected though I shared the right adapter and can see Access Type: Internet in Network and Sharing Center. And restarting results in Access Type: No network access; So I would like to use the Win 10 built-in internet feature which worked without any issues on my other PC

And I don't know if the blank near Network Band is causing any issues!

enter image description here

0

You may want to try these two commands in the Command prompt. They fixed up the exact same problem:

  1. Open a command prompt as admin.

  2. In it, type the following:

    netsh wlan set hostednetwork mode=allow ssid=name key=password
    

    where name is your chosen network name and password is your password, followed by:

    netsh wlan start hostednetwork
    

This is a command line version of the switch found in the Settings app... Hope it helps!

See: Win10 Error: "We can't set up mobile hotspot." for more information using the same method.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.