0

I have tried multiple times now to install jdk 8 in my windows 7 64-bit machine but have failed.

I have downloaded the 8u111 setup file named "jdk-8u111-windows-x64.exe" and 8u112 setup file named "jdk-8u112-windows-x64.exe" from Oracle downloads page and have tried to install the jdk with both versions.

I am running it as an administrator and i have also uninstalled previous java versions from my system.

The installer is opening right and after clicking on next , it progresses for the 1st part smoothly and the progress bar is filled completely but when it goes on to the 2nd progress bar , it just stops and the progress bar doesn't even start.

I have tried with both the versions but am getting the same result .

What do i do ? Please help me !!

Edit: As instructed by Ramhound,i checked the log file jusched (in temp folder) and found the following 2 errors :

[2017/01/16 00:13:54.880, jre.exe (PID: 10076, TID: 11984), BrowserControl.cpp:351 (ui::BrowserControl::execJScriptUnsafe)]
ERROR: script->getIDsOfNames failed with COM error 0x80020006 (Unknown name)

[2017/01/16 00:13:54.910, jre.exe (PID: 10076, TID: 11984), BrowserControl.cpp:817 (ui::BrowserControl::Invoke)]
ERROR: Exception with message 'JScript execution error' caught

I am not getting what these means , Please help!!

1
  • @Ramhound i have found 2 errors and have edited the post with the details. I cannot get a sense of what those errors means. Could you please help? – Nirvana Jan 15 '17 at 19:28
0

I have the same problem on my Windows 7 machine, for a long time now.

The problem as I understand it, is that when the JRE installer (JRE installation is part of the JDK installation unless you de-select it) is trying to present some HTML, apparently containing some JavaScript (like the "3 billion devices use java" banner), using the some "BrowserControl" library, which I guess will use some Internet Explorer components, via Microsoft's MVC, some VC C++ redistributable or .NET framework classes. That fails here. It's likely that on a fresh install this won't happen, since there are some buggy/incompatible components involved. It looks like the java installer tries to execute JScript on the BrowserControl that causes an unhandled exception.

Anyway, the problem can be worked around by running the java installer from the command line and giving /s as an argument, for a silent (i. e. non-interactive installation). The UI triggering the error won't be presented and you'll end up with a default install of the JRE.

BTW, the JDK 9 does present a broken UI on my machine, with the expected checkbox and buttons present but without labels and unclickable. Thus the dialog box can only be closed with the "X" button top-right, which will cause the JDK installation to go on and eventually complete successfuly.

So, I suggest you

  1. download the offline JRE installer separately
  2. install JDK normally, but with the JRE option deselected
  3. install the JRE on the command line using <path-to-the-jre-installer-exe> /s

Or, actually, I think the JDK installer takes an /s option, too. So unless you need to change options, that'll do.

If you do need to set some options, you can do that with additional options on the command line, see this StackOverflow question, or this document describing the JRE 6 installer. AFAIK these options haven't changed.

Hope this helps!

PS: The problem is known, but apparently largely ignored by Oracle:

  1. https://community.oracle.com/thread/3912749
  2. OpenJDK bug report. They think it's solved, but it's not. I just had the same problem installing JDK and/or JRE 9.0.1 on my machine today and I can reproduce the problem every time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.