2

I'm trying to install the whereis command on alpine linux 3.5

Actually I'm running the following command:

apk add --update whereis

But it is not working since I get this error:

fetch http://dl-cdn.alpinelinux.org/alpine/v3.5/main/x86_64/APKINDEX.tar.gz
fetch http://dl-cdn.alpinelinux.org/alpine/v3.5/community/x86_64/APKINDEX.tar.gz
ERROR: unsatisfiable constraints:
  whereis (missing):
    required by: world[whereis]

It seems there is not a package whereis, surely I miss something. What should I do to get the whereis command?

10

You need to install the util-linux package:

apk add --update util-linux

Which contains the whereis binary.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.