4

Well I had the problem that bluetooth was always off. I go to configuration->Bluetooth and everytime I tried to put it off just returns to off a while after. I tried with this command:

aptitude install bluetooth

and then ran

/etc/init.d/bluetooth start

after that I ran /etc/init.d/bluetooth status and this is what shows:

● bluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; disabled; vendor preset: disabled)
   Active: active (running) since Tue 2017-01-17 21:13:47 UTC; 29s ago
     Docs: man:bluetoothd(8)
 Main PID: 7939 (bluetoothd)
   Status: "Running"
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/bluetooth.service
           └─7939 /usr/lib/bluetooth/bluetoothd

Jan 17 21:13:47 kali bluetoothd[7939]: Error adding Link Loss service
Jan 17 21:13:47 kali bluetoothd[7939]: Not enough free handles to register ...ce
Jan 17 21:13:47 kali bluetoothd[7939]: Not enough free handles to register ...ce
Jan 17 21:13:47 kali bluetoothd[7939]: Not enough free handles to register ...ce
Jan 17 21:13:47 kali bluetoothd[7939]: Current Time Service could not be re...ed
Jan 17 21:13:47 kali bluetoothd[7939]: gatt-time-server: Input/output error (5)
Jan 17 21:13:47 kali bluetoothd[7939]: Not enough free handles to register ...ce
Jan 17 21:13:47 kali bluetoothd[7939]: Not enough free handles to register ...ce
Jan 17 21:13:47 kali bluetoothd[7939]: Sap driver initialization failed.
Jan 17 21:13:47 kali bluetoothd[7939]: sap-server: Operation not permitted (1)
Hint: Some lines were ellipsized, use -l to show in full.

My computer is a sony VAIO SVF15A17CLV.

Thank you!!

Edited: After running the service restart command some of you suggested I got the following output:

● bluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; disabled; vendor preset: disabled)
   Active: active (running) since Thu 2018-05-03 23:44:12 UTC; 5min ago
     Docs: man:bluetoothd(8)
 Main PID: 3882 (bluetoothd)
   Status: "Running"
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/bluetooth.service
           └─3882 /usr/lib/bluetooth/bluetoothd

May 03 23:44:12 kali systemd[1]: Starting Bluetooth service...
May 03 23:44:12 kali bluetoothd[3882]: Bluetooth daemon 5.36
May 03 23:44:12 kali systemd[1]: Started Bluetooth service.
May 03 23:44:12 kali bluetoothd[3882]: Starting SDP server
May 03 23:44:12 kali bluetoothd[3882]: Bluetooth management interface 1.12 ...ed
Hint: Some lines were ellipsized, use -l to show in full.

Seems better but it is still not working. When I go to bluetooth settings it's always off. After I press start it stays like the following image:

Bluetooth settings turned off

PS: I know is not a hardware issue because if I boot with windows 10 it works properly.

9 Answers 9

16

I believe we were having the same problem. My Bluetooth would not turn on and would remain in the off position. Here is what I did to fix this problem:

service bluetooth restart

This restarted the Bluetooth service and I was able to turn it on and it stay on. I was also able to see Bluetooth devices and connect to my headphones again.

2
  • I runned the command you said but it's still not working properly. Although the messages now seem to be better than before. I'll update the question with the new info. May 4, 2018 at 2:53
  • this worked for me Dec 6, 2020 at 14:29
4

I had the same problem a few minutes ago, until I restarted the Bluetooth service from the terminal as a root user. I fix it by by typing on the terminal:

sudo service bluetooth restart

On systemd systems:

sudo systemctl restart bluetooth

Then go back to settings and under bluetooth menu, you will have the available devices.

2

I did the following to fix the issue.

I started with a service restart:

 $ sudo service bluetooth restart

Then system control restart:

 $ sudo systemctl restart bluetooth

Went to the bin directory:

 $ cd //bin

Then ran the service file as an exec found in bin

 $ sudo ./bluetoothctl

With bluetoothctl, use terminal commands in blutoothctl to scan (by turning it on)

 $ scan on

Then connect the device (use the digit ID of the device without the name, copy and paste is quick):

 $ connect 00:00:00:00:00

*Note, double check rfkill and make sure it is unblocked. If blocked the following (assuming bluetooth ID is listed as device 0) will unblock it:

 $ sudo rfkill unblock 0
1

I've made a little newbie script to get Bluetooth on your device automated.

  • Open Leafpad and copy&paste this text and save as bt without extension e.g., .sh or anything else into the folder /bin.

  • Go to the folder /bin/ and look for bt.  Right-click the file, choose propereties, and make the file executable.

  • Then open terminal @root and type bt.

and you're good to go.

#!/bin/bash   


if [ $(id -u) != "0" ]; then
    echo
    echo -e "!! You need to be logged in as \e[101m"!!Superuser!!"\e[0m" "\e[39m to run this script !!" >&2 "\e[0m" 
    echo
exit 1
fi
read -p "Are you sure you want to start Bluetooth y/n ? " -n 1 -r
    echo    
    if [[ ! $REPLY =~ ^[Yy]$ ]]
    then
    [[ "$0" = "$BASH_SOURCE" ]] && exit 1 || return 1
fi
    echo
    echo -n
    read -t 1
    echo -n -e "\e[39m"!! Starting "\e[34m \e[5m"Bluetooth "\e[25m \e[39m"Manager !!"\e[0m"
    echo
    read -t 1
    echo
    echo -n -e "!! Take the \e[34m"Blue "\e[39m"pill and Enjoy the Ride !! "\e[0m"
    echo
    read -t 1
    echo -n "!! working on it !! "
    echo
    read -t 1
    echo
    echo -n "!! Loading Update !! "
    echo
    read -t 1
    echo
    sudo apt-get update
    echo
    echo -n -e "\e[31m"!! "\e[39m"installing missing drivers  "\e[31m"!! "\e[0m"
    echo
    read -t 2
    echo
    sudo apt-get install bluetooth
    echo
    echo -n -e "unblocking bluetooth using \e[101m"Rfkill"\e[0m" unblock all"\e[0m"
    echo
    read -t 2
    echo
    sudo rfkill unblock all
    sudo /etc/init.d/bluetooth start
    echo
    echo -n -e "\e[31m"!! "\e[32m"You re good to "\e[34m \e[5m"Go "\e[25m \e[31m"!! "\e[0m"
    echo
    read -t 1
    echo
exit 1
fi
3
  • i dont know how that works ,, Dec 29, 2018 at 0:02
  • well i was just about to post it with the code blocks thx annyways ;) Dec 29, 2018 at 0:13
  • looks fantastic well i didnt see that @ first lol i never posted annything on anny forum like a code li was already saying damn why is my text so big , :) Dec 29, 2018 at 0:16
1

For me, starting the service worked.

/etc/init.d/bluetooth start

I was able to find the bluetooth device and connect.
Then I had tried to enable it using

bluetooth manager / bluetooth adapter - no go
service was not running for me. 
0

Run sudo systemctl enable bluetooth this will add the service bluetooth to the startup process even after reboot you can do this with other system services.

0

1.) root@a:~# sudo /etc/init.d/bluetooth status

2.) root@a:~# sudo /etc/init.d/bluetooth start

then after that you can go setup your Bluetooth. I hope this helps

0

Dell Inspiron 15 3537 running Kali

First i updated the bios version to A12.

It took me couple of days figuring out and breaking my head, but finally it worked for me

I assumed that mere starting the service didn't get BT to work. While checking it's status it was active (running), but in the above line it printed disabled .

# systemctl enable bluetooth.service
# systemctl start bluetooth.service
0

There are many reasons which may cause such issues and sometimes restarting the Bluetooth services simply solve the problem. Run: sudo service Bluetooth restart and you will able to connect with your Bluetooth devices now. Also I have seen that this problem causes again and again sometimes after day for that I have created a alias for it in .bashrc or .zshrc file which you may be using like alias bt = 'sudo service bluetooth restart'.

Then whenever I face such issue I just have to run bt in terminal to solve it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.