0

I'm running a very stripped down Ubuntu, 14.04 on some systems and 16.04 on others. They are all fairly spartan, leaner than Lubuntu, built from the mini.iso with X and Openbox.

How can I set a really large font on the terminal emulator xvt? I have lxterminal set to 22 and that is pretty good for me.

Or if nobody can tell me how, maybe you can suggest a place to ask. Thanks for reading.

= = = = = = = =

Added: In light of Zeno of Elea 's suggestion, which was a very helpful starting place, I've played around with the commands like:

xvt -fn -*-*-*-*-*-*-28-*-*-*-*-*-*-*

and the corresponding statements in ~/.Xresources, like:

xvt*font: -*-*-*-*-*-*-28-*-*-*-*-*-*-*

and the similar:

xterm*font: -*-*-*-*-*-*-28-*-*-*-*-*-*-*

and reloading .Xresources. With some numbers I CAN get a response. Apparently xfontsel can see fonts that xvt can't use, but tries to. Some numbers actually DO change the font size slightly but, so far, none adequately. The result from changing .Xresources, reloading it, and entering xvt in lxterminal are not in all cases the same as issuing the corresponding command directly with the -fn option. Gofigger.

Entering the commands in lxterminal with the -fn option, at the moment, with "32", I get "Floating point exception", exit code 136, and no xvt. Some numbers get me an instance of xvt, but NO visible characters at all - only the cursor highlight is visible. Looks like it takes and responds to commands but I'm typing blind as if the color scheme was black on black. Using -bg option to change the bg color to red results in the same situation with an apparent color scheme of red on red. In both cases with a visible cursor highlight in white.

I've seen other error messages that I failed to record and can't reproduce at the moment. I'm pretty sure one of them was "out of bounds".

I have tried installing more fonts and that was enlightening. Numbers that before resulted in error messages only, or xvt instances with an appearance of a black on black color scheme, albeit with visible white cursor, now work. So far the largest number I've gotten to work is "28" which results in an xvt terminal at the lower edge of usability, about the same size as setting lxterminal to "16", whereas my preference with lxterminal is 22.

So one path to a comfortable font is clear. I can install every font in the repo and try them one at a time. I should have an answer before the glaciers return (I figure CO2 is buying me a little extra time). Can anyone suggest a better way, or where I might ask if nobody can? Or any solution better than the present one of letting xvt pick whatever 28 pixel font it likes?

= = = = = = = =

Second update: By checking fonts one at a time and specifying them more closely, rather than letting xvt choose any 32 pixel font it likes, I've gotten several 32 and one 34 pixel fonts to work. It helped to pay attention to the preview feature in xfontsel. The best of so far is

-*-terminus-medium-r-*-*-32-*-*-*-*-*-*-*

Which seems pretty good. Not as nice as the "Monospace" that lxterminal and geany use, but it will do. Somebody may suggest a completely different way of doing this, but assuming not, the remaining part of the question seems to be:

Can anyone suggest good fonts that have a pixel size of 32 or higher? I'm assuming that "Monospace", which seems very legible and clean, isn't available in a format that xvt understands. If I'm wrong about that, or if you know a way to make it work, I'd appreciate elaboration.

0

If your speaking about rxvt or urxvt / rxvt-unicode you can use the .Xresources file to configure the termininal with the rxvt.font setting.

  • Thank you, but I mean xvt itself, not it's more modern descendents. It's a wee bit lighter, but still does all I need (except be legible) and if I can make it work, I'd like to. If nothing else comes along perhaps I can find an example of what you're writing of and try adapting it. At worst it won't work. I've messed with .Xresources, sometimes even sucessfully, but it's been kind of hit and miss. I don't really understand the nomenclature rules there; I just copy and paste and guess at changes and start over if it doesn't work. – Lew Rockwell Fan Jan 18 '17 at 7:27
  • Tried to edit that but time was up. I should mention that I have tried adapting instructions for rxvt in the past without sucess. Not sure if I screwed it up or if the proper method is sufficiently different or the adaption sufficiently non-obvious that I can't get there from here so to speak. Xvt is old and doesn't seem to have an active forum or mailing list AFAIK. – Lew Rockwell Fan Jan 18 '17 at 7:37
  • I believe it was abandoned pretty much after rxvt took off and superseded it. The syntax of the Xresource file is rather terse and easy to make a mistake. Xvt was made as a replacement for xterm. Its a shot in the dark but perhaps the xvt will respond to xterm.fonts and use a non xft based old style font string. – Zeno of Elea Jan 18 '17 at 7:55
  • Thanks again. As a matter of fact adapting what I got to work for xterm is one of the last things I tried when I worked on this a while back. This: xtermfont: --fixed-medium----18------iso8859-* in .Xresources works for xterm, but this xvtfont: --fixed-medium----18------iso8859-* doesn't affect xvt. – Lew Rockwell Fan Jan 18 '17 at 8:08
  • To be clear, NEITHER of the above affected xvt. The first DID affect xterm. Just now I tried this: xvt*font: DejaVu Sans Mono:pixelsize=20 and reloaded .Xdefaults. Didn't work either. – Lew Rockwell Fan Jan 18 '17 at 8:41
0

I'm going to accept Zeno's answer, because:

  1. It literally answers the question - you set xvt font size in ~/.Xresources.
  2. It started me on the way to an effective solution. Not yet a perfect solution, but pretty good.

But I'll point out a few pitfalls for anyone trying to do the same thing with some legacy app so they can make their own mistakes and not repeat mine:

If there is any way to know what font package has the magic font for your app before installing and trying it, damfino it. (Trial, error) x N, where N is a large number.

After installing new font packages, some seem to be available immediately and soom seem to require a reboot. Or maybe it would do to restart X.

Use xfontsel and pay attention to the preview. If the preview doesn't show a legible font, odds are it's a waste of time. Giving your app a general direction about a font that has a lot of asterixes in it may fail even if there ARE fonts installed and available to the app that match that wild-card spec and WILL work. You will have to try specifying them more precisely to find out and trying them one at a time to find out. Leave the app a choice of fonts, it will pick one that fails and give you a misleading error message or no error message. This is Murphy's Law, number 76.

If the app has a command line arg for font, as this one does, experimenting with the command line is a quicker way to find what works. In using .Xresources, note that specs for both individual programs and CLASSES of program are possible. In this case for example

XTerm*font: -*-terminus-medium-r-*-*-32-*-*-*-*-*-*-*

works for xterm and xvt, whereas

xterm*font: -*-terminus-medium-r-*-*-32-*-*-*-*-*-*-*

works only for xterm and

xvt*font: -*-terminus-medium-r-*-*-32-*-*-*-*-*-*-*

works only for xvt.

When I say it "works", that doesn't mean it produces the SAME results in both apps - it does NOT - but it is recognized and acted upon. Don't forget to reload .Xresources:

xrdb ~/.Xresources

FWIIW: The best I've found for my purpose so far is:

xvt*font: -*-terminus-medium-r-*-*-32-*-*-*-*-*-*-*

I'm still looking for something better, but finding a better font isn't really the question I asked. Suggestions will be welcome though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.