1

I've recently bought an TP-LINK UH400 USB hub with an USB cable (SSK, 3.0 type A, one male and one female). I've connected the male side of the cable on the back of my PC (in a 3.0 slot) and the female one into the USB hub. But when I boot in, if the hub's connected it takes almost a minute, while when it's unplugged it takes around 8 seconds. Please help!

Specs: CPU : AMD FX-4300 GPU : ASUS Raedon R7 370 Motherboard : ASRock 970 Pro3 R2.0 RAM : 8GB + Seagate HDD (1 TB) + HyperX Fury SSD (120 GB)

  • Do you have any "boot from external device" or "USB" or something configured in BIOS? If yes, disable it in the boot priority screen. – Lenniey Jan 18 '17 at 10:31
  • I tried enabling "Fast boot" which will disable USB booting but the base boot will be boosted. But that didn't worked. I also found something out : while in the BIOS screen or BIOS menu, if the USB hub is connected the BIOS will lag (I've connected the hub while in the BIOS menu). – Armand Florin Jan 18 '17 at 15:17
  • What is connected to the hub, if anything at all? – Lenniey Jan 18 '17 at 15:50
  • The problem appears even if nothing is connected. The only thing between the PC and the hub is the USB cable. – Armand Florin Jan 18 '17 at 18:28
  • 1
    UPDATE : At least for now, I've managed to fix the problem by switching the cable's male side to another 3.0 slot. And now it's working good. I'll let you know if another problem appears. Thanks for the assistance! – Armand Florin Jan 18 '17 at 18:30
1

Plugging into a 2.0 USB port fixed the problem for good.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.