After changing one HDD I accidentally connected my hard drives in reverse order, so non-system HDD became master and SSD with the system became slave.

The interesting thing is, as I started the system USB devices did not respond. Both keyboard and mouse were working fine in BIOS, but Windows somehow ignored them (despite USB ports being still powered up).

I tried to restart, nothing changed. Swapping the discs solved this problem.

What happened there?

  • You should change the configuration of USB within BIOS before you make such a change in the future. My guess you need to enable legacy USB support or similar functionality before it will work. – Ramhound Jan 18 '17 at 15:00
  • If swapping the drives' places resolved the problem, I believe you won't encounter such issues again. However, if you do always make sure you have the primary drive connected to the first available SATA port on the mobo and then configure secondary drives afterwards. If you accidentally mess something with the BIOS configuration, you can always Reset BIOS and get its settings back to their factory default state, so you could re-configure them. P.S. Don't forget to back up regularly to avoid potential data loss. Good luck! I hope this was helpful. :) – SuperSoph_WD Jan 19 '17 at 8:27
  • 2
    @Ramhound: But guys, why does it even matter? I changed nothing except boot order (moved SSD above DVD), also the BIOS itself had no problems with USB devices (I used them to enter setup, in the first place). How is USB linked to disc drives? – NoMercyIncluded Jan 19 '17 at 11:09
  • 3
    @SuperSoph_WD: as above. I just don't know why and I don't want to leave it as one of those moments where "well, something weird happened, lets assume it's magic". – NoMercyIncluded Jan 19 '17 at 11:10
  • 11
    sata does not have master and slave... – Journeyman Geek Jan 21 '17 at 11:17

Different BIOSes work differently. It may be attributed to a Boot Order, whether configurable or not, or it might be attributed to your USB hard drive volume being marked as an Active (bootable) partition, while your primary drive is not or takes second fiddle to removable Active partitions.

If you don't intend to boot from a drive, be sure to remove the Active flag. Use DISKPART (command window) to accomplish this:

Open Start, type CMD, right-click cmd.exe or 'Command Prompt' and select 'Run as administrator'.

Follow along these commands:

  SEL VOL {number or drive letter}  (aka SELECT VOLUME)
if it says 'Active: Yes', then type:

Repeat for other volumes that do not need to be Active bootable partitions. Check to make sure your C (boot) volume is, in fact, Active. If not, mark it so with the ACTIVE command. This is how your BIOS should scan to determine which drive to boot from, when it's in doubt.

You can always mark a partition as Active within Windows Disk Management, but DISKPART is the only practical way to undo that action and remove the Active flag.

  • I deleted my answer because somebody decided to edit and vandalize my post with a link to third-party software and comments about their ass, and I'm powerless to do anything about it because my rank isn't 2,000 or more. So I will just delete my presence from this site until it gives authors unrestricted access and control over their contributions. I also don't like that I can't post comments on this site, so I use other forums instead. – raccoon Aug 30 '18 at 23:19

It could be that you did not reconfigure the bios when you mis-organised your physical setup. Bios'es aren't as smart as you might think. Actually, I think the simpler they make the built-in bios software, the more secure it is, since there is less code to go wrong at the lowest level of a computer.

I'm not sure if this helps, but I had issues with IOMMU and USB 3.0 when I switched from using Windows as my main OS to Ubuntu/Linux. You should also note that if you are having issues with USB 3.0 ports, the '3.0' might be the issue, as USB 3.0 is known to go out frequently.

  • BIOSes are smarter thank you think. Swapping a disk configuratoin should not issue an error, because every BIOS scans all of the system buses and detects every hardware at every boot since it's a nearly no-time process. – Gabor Garami Apr 4 '17 at 10:58

BIOS took in the slave's ISO and used it to run the master. the path configuration of the drivers were not found which ignored USB devices.


When you can't boot from the required disk, the BIOS followed the search order and booted from the next available boot device. In doing so, it enumerated USB boot devices. Having captured USB controllers/boot devices, it did not correctly release or re-init them for Windows.

This is just a guess. On the other hand, what you report is a well-known common problem, and no other explanation has ever been suggested.

Not the answer you're looking for? Browse other questions tagged or ask your own question.