0

Trying to run make in cygwin, I get the following error message:

$ make clean
Error: cmp command not found, please install diffutils
../../../../Makefile:489: recipe for target 'clean' failed
make: *** [clean] Error 1

But, diffutils are installed and cmp exists:

$ ls /bin | grep "cmp"
bzcmp
cmp.exe
infocmp.exe
lzcmp
xzcmp
zcmp

I tried reinstalling, but that didn't change anything:

$ apt-cyg remove diffutils
Removing diffutils
Package diffutils removed

$ apt-cyg install diffutils
Installing diffutils
diffutils-3.5-2.tar.xz: OK
Unpacking...
Package diffutils requires the following packages, installing:
cygwin libiconv2 libintl8 libsigsegv2
Package cygwin is already installed, skipping
Package libiconv2 is already installed, skipping
Package libintl8 is already installed, skipping
Package libsigsegv2 is already installed, skipping
Package diffutils installed

What am I doing wrong?

2
  • How is written the clean rule ?
    – matzeri
    Jan 19 '17 at 10:20
  • @matzeri If you really want to know you can look in the repository, but even if I don't put in a rule it doesn't work. I did do a complete reinstall of cygwin and that fixed it.
    – iFreilicht
    Jan 19 '17 at 10:26
0

This is a sledgehammer solution, but in the end I just completely reinstalled cygwin and everything worked fine again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.