2

I am having some trouble and i need a kind/patient individual to assist me. I am new to the world of computers. When i got the computer i had trouble installing bitmessage so a friend suggested i alter the /etc/apt/sources.list. It worked and all was well (i was able to install and use bitmessage via terminal). So i tried to install openshot video editor via the synaptic package manager and that went great until i try to use it and nothing will happen(more on this later).So in my wisdom i assumed because the updates version was removed from the /etc/apt/sources.list.that maybe i should edit it to the original state(i saved it before altering as my friend suggested). So i opened the nano /etc/apt/sources.list. and copy/pasted it to the original text put in by the installer. After doing so i can no longer access the synaptic package manager and am getting the following message:

E:malformed line 5 in source list/etc/apt/sources.list (URI)
E:the list of sources could not be read.
go to the repositiory dialog to correct the problem
E_cache->open()failed,please report

I have attached the original /etc/apt/sources.list text by the installer and also the one my friend made for me. The openshot is installed but simply does nothing. I am not sure if i have saved the sources.list correctly or for that matter what is going on.

Thank you for your time, wisdom, and patience.

Original sources.list :

enter image description here

  • 1) it's better to copy/paste content of a file as text, not as graphic. in your case there is an issue on line deb cdrom:[Debian.... but this line did not fit on the screen, so we can't see it all. 2) since you are new to computers, i would suggest more user friendly editor, ie gedit. 3) everything after a # sign is a comment. 4) can you please comment out 5th line deb cdrom:[Debian... by putting # at the begining of a line, and try again with synaptic? this line refers to cdrom, and i don't think you use it after installation anyway. – rsm Jan 19 '17 at 22:55
1

The 5 th line is:

deb cdrom:[Debian GNU/Linux 8.1.0 _Jessie ...

You should comment the cdrom source and add the main repo to your sources.list

There is an example to the sources.list (It will work for you. You can also choose the nearest mirror):

#

# deb cdrom:[Debian GNU/Linux 8.1.0 _Jessie ...

# deb cdrom:[Debian GNU/Linux 8.1.0 _Jessie

deb http://ftp.fr.debian.org/debian/ jessie main
deb-src http://ftp.fr.debian.org/debian/ jessie main

deb http://security.debian.org/ jessie/updates main
deb-src http://security.debian.org/ jessie/updates main

# jessie-updates

deb http://ftp.fr.debian.org/debian/ jessie-updates main
deb-src http://ftp.fr.debian.org/debian/ jessie-updates main

Save your sources.list then run the following commands:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

The error should be disappear when you run synaptic.

  • 2
    Thank you so much. I hashed out the cd rom line and then added your sources list text. works like a charm. – bbr001256 Jan 22 '17 at 14:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.