3

I recently ran an aggressive shredding program on a Toshiba external spinning drive, then a recovery program on it to check that the shredding worked, and then non-quick reformatted it with NTFS. I then tried to run the (Windows 7) "Error Checking" tool in the drive's Properties menu. When I ran this, it kept freezing at the very end, so I ran chkdsk /F /R /X /B G: hoping for a better message. After losing the output because I ran out of window buffer, I ran it yet again, and got the following message. The drive is empty except for a text file and some system folders that were created automatically.

...
99 percent complete. (244122093 of 244135076 free clusters processed)    
99 percent complete. (244127093 of 244135076 free clusters processed)    
99 percent complete. (244131093 of 244135076 free clusters processed)    
  244135076 free clusters processed.                                        

Free space verification is complete.
Adding 244135076 bad clusters to the Bad Clusters File.
Windows has made corrections to the file system.

 976657919 KB total disk space.
     21588 KB in 8 files.
        16 KB in 15 indexes.
 976540304 KB in bad sectors.
     96011 KB in use by the system.
     65536 KB occupied by the log file.
         0 KB available on disk.

      4096 bytes in each allocation unit.
 244164479 total allocation units on disk.
         0 allocation units available on disk.
Error in writing the output log.
Error in writing the output log.
Error in writing the output log.
Error in writing the output log.
...

This looks to me like it is telling me that all the (almost 1TB) free space on the drive has been marked as bad and added to the "Bad Clusters File". Am I reading this right? Does this mean my drive is completely bad?

UPDATE:
For the life of me I couldn't find a Toshiba-specific hard drive diagnostics tool on their very frustrating website. But I downloaded Crystal Disk and got the following. It looks like most of the raw values are 0 however, including the "Reallocated Sectors Count".

enter image description here

UPDATE:
I ran a second non-quick format, and ran Crystal Disk again, getting the info below. It is virtually the same as the previous run. I then ran chkdsk again, and ran Crystal Disk again and got the same info below. I am thinking the zero values below are not actual values, but just an effect of Crystal Disk not being able to access the real SMART values. I have tried without success to find a Toshiba-specific tool, but so I'm not sure what to do at this point.

I noticed that before running chkdsk, the properties menu showed the disk as being totally free, and after running it, as totally full. Also, I forgot to mention that every time I've run chkdsk, at the end it displays an error about failing to write to I think a log file. It displays it repeatedly.

enter image description here

8
  • 1
    can you get SMART stats on the disk? what are the reallocated sector count and Current Pending Sector count? – Frank Thomas Jan 20 '17 at 4:42
  • 1
    yes, chkdsk is saying all, but a tiny amount of space is bad. How long did chkdsk take to run? 1 day, 1 week, or etc? That is highly unusual, and I would check the SMART data to see if this is true. – cybernard Jan 20 '17 at 5:25
  • 1
    I'd definitely follow the advices given by the guys above, @xdhmoore! Chkdsk cannot give you accurate data about the state of your hard drive. It's best to check that by running the HDD's brand-specific diagnostic tool or a third-party alternative that let's you know what is the health state and SMART status of the drive. However, I'd strongly recommend you also make sure you have backed up all important files from this HDD somewhere off-site (e.g. external drive) before you proceed with the troubleshooting. This is how you will avoid any potential data loss! Good luck! – SuperSoph_WD Jan 20 '17 at 8:40
  • As @SuperSoph_WD said, your next step is to run the hard drive manufacturer's diagnostic software. – I say Reinstate Monica Jan 20 '17 at 15:26
  • Updated with the best info I can find so far. I don't see anything that looks helpful to me, but my knowledge on this sort of thing is limited. – xdhmoore Jan 21 '17 at 7:23
0

This is the Toshiba SATA to USB3.0 controller PI-519 v1.3. Remove HDD from case and use another generic SATA to USB3.0 or connect via SATA cable on PC. Problem is solved and there are no bad clusters by using chkdsk.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.