1

I am currently playing a game called Microsoft Train Simulator on my Windows XP computer. Train Simulator supports a maximum resolution of 1024x768.

My graphics card, ATI Mobility Radeon 9000 IGP, uses a 1280x800 resolution which is slightly larger. As a result, the game appears slightly distorted when playing.

I have an option not to automatically stretch the screen in my BIOS. This option works until ATI's driver begins running, at which point the BIOS setting is ignored.

How can I force XP not to stretch the display?

While my question looks similar to Force games stretch into full screen in lower resolution? my driver does not have Catalyst Control Center.

Edit: My post did not state originally that this was the original 2004 driver from ATI. I'm correcting this now. I've tried installing the 2006 drivers with no change. There are no later drivers.

6
  • 1
    Catalyst Control Center may come with drivers, but it's not part of them. Have you tried to download it? -- Have you checked the latest driver version which works reliably with your graphics card? -- Is there no monitor setting you can use? -- Just a few thoughts here. – Run CMD Jan 20 '17 at 11:38
  • @ClassStacker I just said that the driver came preinstalled with my computer. At that time (2004) I'm not sure CCC even existed. I also mentioned a BIOS option, but this only works until the ATI driver loads. – user648246 Jan 20 '17 at 11:39
  • 1
    There should be some form of control program for your graphics card. If it doesn't have that option you're probably out of luck. – Seth Jan 20 '17 at 11:40
  • @MarkYisri I don't see how your response relates to my comment, and no, you didn't say that you use an original 2004 driver; at least not in your first version of your post which is the basis for my comment. It might be a godd idea to re-read my comment and give it a second thought. – Run CMD Jan 20 '17 at 11:44
  • (Now as comment) Did you try to remove hardware acceleration? control panel->display->(advanced settings)->troubleshoot-> (you may have a 'change settings' button to clic on) Then reduce or put it to None – Jonathan Jan 20 '17 at 12:59
0

Sorry I cannot comment so I put this in answer... I don't know if this would do it for you, but as an alternative solution many games allow for the alt+enter combination in order to play the game in a window rather than full screen. That way there would be no stretching, though you might not like playing in a window smaller than the screen.

1
  • No, this game has an option for a windowed mode... which is not what I want. But thanks for the suggestion anyway! – user648246 Jan 20 '17 at 11:49
0

I finally found a solution on how to do this.

I have a very old ATI graphics card (2004) so using Catalyst Control Center was not an option. Instead, I had a very primitive control panel.

The problem with that was that I overlooked several helpful options, especially this one:

Radeon Graphics Control Panel display tab

When you click the Panel button, a very helpful window comes up:

Panel window

That last option should be unchecked. The display will no longer stretch at lower resolutions. Rather, it will put a black border around the screen.

I hope this information helps other ancient ATI card users.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy