1. Briefly

Keyboard layout sometimes not switch for me, if I print my texts fast. It would be nice, if my keyboard layout switching each time, when I press Alt+Shift. I will approach any built-in solution or gratis software.


2. Detail

I have Windows 64-bit EN; problem many times reproduced for me in Windows 32-bit. I have 2 keyboard layouts — English and Russian. I switch my keyboard layout use Alt+Shift hotkeys. Sometimes layouts not switched for me, if I print fast. If I print slow, problem not reproduced for me.

For example, in demonstration GIF keyboard layout not switched for me 2 times. In GIF one can see that I correct press Alt+Shift.

Original GIF:

Original GIF

0,07 speed:

0.07

The problem reproduced for me in Notepad or any others applications.


3. Did not help

  1. I don't find setting in Control Panel\Clock, Language, and Region\Language.
  2. I don't find in Internet possible solutions of this problem.

4. Do not offer

  1. Please, do not offer use another shortcuts for switching between keyboard layouts. I don't want it. I used to use Alt+Shift.
  2. Yes, I use program for change words, printing in wrong keyboard layout — Mahou — but sometimes I need switching between keyboard layouts manually.

Thanks.

  • Could you try in default Notepad, and take a look at your taskbar? – BladeMight Jan 20 '17 at 17:38
  • 1
    @BladeMight, problem reproduced for me in Notepad: i.imgur.com/LMSs7QW.gif . Thanks. – Саша Черных Jan 20 '17 at 17:53
  • 1
    What about your taskbar's current keyboard layout? And also try switching layout with one key(Mahou have this feature) and say how it works. And which English layout do you have English(US) or another? If another there is problem with English(US) to appear sometimes by itself even if it not selected. And since it is Windows 10 try using Win+Space instead of Alt+Shift. – BladeMight Jan 20 '17 at 18:10
  • @BladeMight, // 1. I use my own Russian and English keyboard layouts (my Colemak modifications), but problem is reproduced for me in default QWERTY/ЙЦУКЕН keyboard layouts. // 2. When I switch between my keyboard layout, I see in taskbar only ENG and РУС. I disable Ctrl+Shift and Right_Ctrl use SharpKeys, that I don't get ENG/US keyboard layout. – Саша Черных Jan 20 '17 at 18:41
  • 1
    I fixed it for me by going to advanced settings in Control Panel > Clock, Language and Region > Change input methods thewindowsclub.thewindowsclubco.netdna-cdn.com/wp-content/… and in Override for default input method i.imgur.com/nuz6gWp.jpg select your English and then logout and login and try everything again. – BladeMight Jan 20 '17 at 20:12

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.