0

System-wide, when I type:

.)  

My mac replaces this with:

.) . 

or

.). 

I'm thinking that I must have set some weird autocorrect somewhere? How do I stop it from doing this?

1

Maybe you have "Text Substitution" set up? http://osxdaily.com/2010/07/23/set-up-text-substitution-in-mac-os-x/

  • Hmm, mine looks like this as the default setting: i.imgur.com/FZSukJJ.png . Interestingly, if I type "omw" it does't change this to "On my way!" -- Note, the "." between my link and the word "Interestingly" on this comment was automatically added by the system. So, I suppose it's double-space related. Although ". " doesn't trigger it between sentences. Weirdness. – iRyanBell Jan 21 '17 at 19:51
  • Er, wait a second "Add period with double space" (!) Why is that a default option?? Fixed... – iRyanBell Jan 21 '17 at 19:54
  • @arby glad it worked out! – ljk Jan 21 '17 at 19:55
  • Arby, that's a default option because it's popular in iOS. I didn't even notice it in macOS, but it's certainly a nice shortcut in iOS, allowing you to end a sentence with 2 easy "space" characters. – jimtut Jan 23 '17 at 17:30

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.