Windows on my workstation has been updated recently to a new build... In result of what I lost access to my 2nd partition. In Windows Disk Manager it shows RAW in file system column of broken volume. When I try to browse to the drive on file explorer it suggest that I should format this partition.

Ubuntu 16.04 also doesn't recognize the drive.

I heard about similar problems happening with early "Anniversary" updates. However, I'm using Windows 10 Pro with deferred updates on, so I'm not sure if it is possible that it is still the same issue or just new bug?

I tried to go back to previous build but it didn't help then I installed updated again and tried to install all new patches via Windows update... with no luck.

I also tried to use software to recover the data but it just gives me a file "soup" as a result.

Is there any better way to fix that? Where information about partition file system are stored? Is it possible to change that information manually to NTFS and if yes can it help?


More info about bug.

And here

Edit 2:

This is what I recently found, do you think that fixing boot record might help? enter image description here

Edit 3: Rebuilding partition boot record didn't helped.

  • You can only defer updates for 6 months. Since the Anniversary feature update was released 6 months ago, your system was recently upgraded to that feature update, you did know that right? Don't find causation to your partition being lost when your windows installation was updated to the current feature update, because the two events, likely not connected.
    – Ramhound
    Jan 21, 2017 at 21:54
  • 1
    Windows Updates do, indeed, have a reputation for mangling unknown partitions (e.g. Linux). The only thing that can assure restoring these partitions is to make a full disk image before the update. Sorry, this won't help your current issue, but after straightening it out as best you can, use imaging software such as Macrium Reflect to back up all partitions. Jan 22, 2017 at 3:43
  • 2
    If Linux can’t mount it using either the in-kernel NTFS driver or NTFS-3G, the filesystem is corrupted. This obviously can’t be fixed by rolling back the update.
    – Daniel B
    Jan 22, 2017 at 9:14
  • 3
    You should try to use some image tool to get a perfect copy of that disk before you try to fit it. The tool in your screenshot seems to suggest that the backup record is fine (at least the data makes more sense) so restoring it might be worth a shot.
    – Seth
    Jan 23, 2017 at 11:00
  • 1
    Manipulations can save or destroy the disk (or fail to do anything), so if you do not have backups and if in addition the above data-recovery tools could not save your data, then be aware that there is a risk. First, I find it weird that MiniTool could not touch this partition : Try to follow this How to Convert RAW to NTFS tutorial.
    – harrymc
    Jan 24, 2017 at 20:31

3 Answers 3


The upgrade to Windows 10 may sometimes (rarely) cause a destruction of the disk. The causes are not known at the moment, and my suggestions in the comments for saving the poster's data (about 10000 photos) have not yet been all tested. Nevertheless, the poster has asked me to sum up all my suggestions in one answer that might be useful for future readers as a compendium of recovery tools and methods.

Before starting, please note the difference between recovery and repair operations. The later ones manipulate the destroyed disk and can either save or destroy it (or fail to do anything). If you do not have backups and if in addition the data-recovery tools could not save your data, then be aware that there is a risk of losing everything.

Please also note that data should be recovered to another partition/disk, not to the problematic one. Avoid writing to a partition whose data needs to be recovered.

Free tools

  1. Start the Command Prompt (cmd), launch diskpart and verify that the list disk command shows the destroyed partition and its displayed type. If something is wrong, the partition table needs to be reconstructed.

  2. MiniTool Partition Recovery Free is an excellent tool that can recover data but also repair problems. For the case of a partition becoming RAW, see the tutorial How to Convert RAW to NTFS.

  3. AOMEI Partition Assistant Standard Edition Freeware can repair partitions. Only the paid version ($44.95) can repair the partition type-ID.

  4. Paragon Rescue Kit 14 Free Edition can do various repair operations.

  5. Active Partition Recovery is a freeware toolkit can do various recovert and repair.

  6. Recuva can recover files.

  7. In the Windows Disk Management, try to assign the partition a drive letter (Z) and if successful use chkdsk Z: /f.

  8. Ubuntu has the ntfsfix recovery tool for NTFS disks. See this article for details : How to Fix a Corrupted Windows NTFS Filesystem With Ubuntu.

Shareware Tools

The tools in this section offer a limited version for free that demonstrates their capabilities. The paid version is required for a full recovery operation.

  1. EaseUS Data Recovery Wizard Professional ($56) can recover data.

  2. Recover My Files ($70) can recover files.

  3. DiskInternals NTFS Recovery recovers data.

Commercial tool

Ontrack ($103) is said to be the best data recovery tool, probably the one used by professional recovery services.


This is a known bug - here is a msg from Microsoft on the issue:

Hello Everyone, I want to give a huge Thank You to all who responded with my diagnostic information requests about their “tanked secondary drives”. I’m pleased to say that this information enabled us to identify the root cause of the issue. We are actively building and testing an update to fix this issue into Windows. We’ll deploy the update via Windows Update as soon as that process is finished, restoring access to your files on the affected drives. In all of the cases that we have diagnosed, files were safely intact on the drives – so please, don’t reformat. You can also access your files by connecting the affected drive to a different machine (not running Anniversary Update), if that is an option for you. If waiting for an update is not an option, then rolling back will also restore access to your files. For up to 10 days after installing the Anniversary Update, you have the ability to “go back” or return to the previous build. To uninstall the Anniversary Update: 1. Open the Settings app. 2. Select Update & security and then the Recovery tab. 3.
Under “Go back to an earlier build”, click the Get started button and follow the instructions. (Note: If more than 10 days have elapsed since installing the Anniversary Update or the “Go back” option is otherwise not available; we ask for your patience until a patch can be released)

And later in the thread -

I can confirm that the Cumulative Update KB3189866 has fixed the External HDD RAW issue for me.

Full details found here


You may try Testdisk tool, which can be extremely effective in such situations, it saved me several times already. It's free and open-source, however you may later decide to donate to the author if you find it useful. :-)


Download and run the program, then perform analysis of your disk and see if it finds your partition.

Detailed step-by-step instructions are provided here: http://www.cgsecurity.org/wiki/TestDisk_Step_By_Step

  • Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change.
    – DavidPostill
    Jan 23, 2017 at 21:51
  • Of course I could quote the whole page of instructions from the Testdisk website, but I think there is little reason to do so as anyway the tool has to be downloaded from the official site and it's better if the original poster would follow the up-to-date instructions on the official site. My intention was mostly to let the original poster know about the tool as a possible solution to their problem.
    – ssurba
    Jan 24, 2017 at 20:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.