1

I've just bought a Acer Aspire E5-575G (not the best choice for gaming, but on a budget). I've been happily using it for playing games and browsing the net, but I turned it on again a month after having it to see the "Network Connections" icon turn from LAN to Wireless.

The last connection I had plugged into it was a LAN cable which worked perfectly fine and dandy. I went to "Change network adapter settings" thinking I could change it back to my wired internet to find there was no Ethernet adapter, but just the Atheros Wireless adapter (in this laptop, it's only 72MB/s)

I then restarted my laptop thinking the adapter hasn't started correctly. When I restarted, the "Network Connections" icons briefly flashed the LAN icon with the "No connections X" over it then changed to wireless. Still, no Ethernet adapter was available to select. I then went to Device manager and saw that there was no LAN drivers installed, just Atheros and the standard WAN IP and WAN IPv6 drivers. I then perused the Acer Driver site and found the only available LAN driver for my model of laptop, Realtek. I downloaded a fresh copy of this driver and installed it and got, from what I've looked up, the "Deep sleep" error. I configured my power settings to never sleep or turn off when plugged in, restarted and tried again and got the same error. To add to this, when the LAN driver was working, I never remember it saying "Realtek" anything, but I could be wrong.

Related pages I've looked at:

Acer website

  • 1
    72MB/s is terrible? What kind of Internet connection do you have? Gigabit fiber? – David Schwartz Jan 22 '17 at 6:54
  • Gigabit, but not fiber unfortunately. – Jacob Jewett Jan 22 '17 at 8:25
  • use latest driver from Realtek: realtek.com.tw/downloads/… – magicandre1981 Jan 22 '17 at 19:44
  • used the latest driver and got the same deep sleep error. – Jacob Jewett Jan 24 '17 at 5:57
  • boot linux live dvd and look if it shows up there. if not the nic chip is damaged – magicandre1981 Feb 5 '17 at 8:13
1

You are facing a problem of a hardware device disappearing from a computer whose software configuration didn't as much as change. Furthermore, your Device Manager is not even reporting the existence of the device, as opposed to slapping a warning symbol on it. Hence, the only logical outcome is a hardware failure.

If there is warranty period left on your laptop, you must quickly take it to a repair center.

| improve this answer | |
0

Try to remove all battery source -- unplug, remove battery (if built in, you have to disconnect battery cable from board) -- w8 w8 w8 .. .. .. not more than 1 minute

plug it back, power on your computer, check your eth lan

hope it work, my problem is fixed.

| improve this answer | |
  • Yep tried that with the built-in battery. nothing changed. – Jacob Jewett Feb 3 '17 at 0:28
0

As Fleet Command said, I most likely have a hardware malfunction on this laptop. I ended up purchasing an external Ethernet adapter which is actually better considering its a normal RJ45 connector with WAG light indicators, unlike the "modern" but stupid one on the PC that's engineered to break in days.

| improve this answer | |
  • 1
    You might want to throw fleet command at least an upvote, or even select his as the correct answer in this case. I do consider this an answer but it would be nice to close the loop on the question. – Journeyman Geek May 7 '17 at 0:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.