0

I have a WiFi-connected printer and scanner (Canon MG 5700) that I use from Windows 10. One of the nice features of Windows 10 is that I never had to install any drivers or bloatware to get it working. Windows automatically discovered the printer on the network, and it actually works.

Not only can I print, but I can also scan using the Windows Fax and Scan application.

Occasionally, however, it stops working. When I try to scan something, I get this error message from Windows Fax and Scan:

No scanners were detected. If a scanner is installed, make sure that it is powered on and connected to the computer, and then try again.

This happens even though the scanner is, in fact, powered on, and, according to its own little display, connected to the WiFi.

If I reboot my Windows 10 laptop, it works again, so I'd suspect that the problem is in Windows, and not with the printer.

Sometimes, it's a bit of a bother to have to reboot the computer, so I'm looking for a way to resolve the problem that doesn't involve a reboot. I've tried to close and restart the Windows Fax and Scan application, but that doesn't solve the problem. I've also tried to disconnect from, and reconnect to, the WiFi, but that also doesn't help.

If there's some Windows service or other kind of daemon I could restart, I'd consider that an improvement over rebooting, but I haven't been able to figure out which one to target.

Is there a (fairly) easy way to 'reset' Windows 10 scan and printing so that it discovers that the scanner is, in fact, online?

  • have you tried restarting the print-spooler service? – farosch Jan 22 '17 at 14:23
  • @farosch That service is, in fact, the only one I have tried to restart. Unfortunately, it doesn't help. – Mark Seemann Jan 22 '17 at 14:32
  • does the printer have a sleep function, that could be disabled? and just to verify, thst this is not a driver issue? does the problem persist when installing the canon drivers? – farosch Jan 22 '17 at 14:35
  • What about the Windows Image Acquisition (WIA) service, if W10 still has that? Especially if printing keeps working, that's the one I'd look at. – Thijs van Dien Jan 22 '17 at 14:37
  • 1
    Canon provides a download on their site, that contains nothing more than the pure drivers, so no bloatware here. At least they do for the MG5720 (I don't know what model exactly you have) usa.canon.com/internet/portal/us/home/support/details/printers/… – farosch Jan 22 '17 at 15:00
1

I had the same issue with an HP scanner and it was an IPv6 / IPv4 problem, try to disable IPv6 on the scanner and see if it works. When my PC tried to connect to the scanner with IPv4 worked fine but when it used IPv6 there was something wrong going on. Rebooting the PC flipped the coin between IPv6 and IPv4 and sometimes worked, sometimes not.

1

I have a MG7100 that cannot be found if Windows thinks it is is on a public WiFi network. Removing my 'public' home WiFi network and adding it back as a trusted network fixed it for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.