7

I just reinstalled windows on my laptop and PC and found that I can no longer access laptop drives from the PC by going to e.g. \\MyLaptop\c$

I used to be able to do this, but now I'm getting an error.

Here's the details of the current state:

  • I can see MyLaptop from MyPC under Network.
  • When I click MyLaptop and I can see a shared Users folder.
  • When I try to open \\MyLaptop\C$ I get a login box, but when I enter the credentials (using MyLaptop\LaptopUser format) I get a message: MyLaptop is not accessible. You might not have permissions... (before I was also getting 'access denied').
  • The LaptopUser is the main user (administrator) on MyLaptop and I used to be able to access the drives this way before. It is also added to Security tab of the drive with Full control permissions.
  • Both devices are using the same wifi connection and both are in the same homegroup (not sure if I need it though, I don't remember using it previously).
  • Both devices are using Windows 7 (same as before the reinstall).
  • MyLaptop is on Win7 Home Premium, MyPC is on Win7 Professional.

I know I can share the C drive (or any other drive/folder), but I would prefer not to do this, I know I didn't have to do this before.

Any advice would be appreciated.



Update:

After un-sharing the Users folder on both devices the homegroup now shows no other homegroup computers available, but both computers are still visible under Network. Trying to access the C$ drive of one from another now still shows the login box, but logging in results in Access denied error message.



New Facts:

  • After executing net user administrator /active:yes and setting password for administrator user I can now access the remote drive using that user's credentials. It works both ways with the administrator users for laptop and PC.
  • Therefore my question now is - what is the difference between the built-in administrator account and the non-built-in LaptopUser/PCUser account, which are also administrator type users?, ideally I would like to be able to do this using LaptopUser/PCUser
12
  • 1
    Did you check the firewall yet ?
    – clhy
    Commented Jan 22, 2017 at 17:02
  • Try using the username format of ipaddress\LaptopUser & see if that makes any difference. Check that the LaptopUser is a local admin of the MyLaptop since the hidden admin C$ share is for administrator level access. Seems like a permission or credential issue more than a FW issue since it's actually prompting you for the password when you connect via the SMB protocol; otherwise, you'd get an inaccessible, cannot find resource, etc. type error if I recall correctly. So use the IP address username format, check the account is enabled and local admin, and confirm the password is correct. Commented Jan 22, 2017 at 17:25
  • @pun - windows firewalls are working on both, devices, I tried disabling them, but that makes no difference
    – tsw_mik
    Commented Jan 22, 2017 at 17:44
  • @Walmart - I tried using ipaddress\LaptopUser, but that makes no difference. LaptopUser is an administrator user (in User Accounts, I don't seem to have Users and Groups on this Windows instance) and credentials are ok, since they are working on the laptop. Laptop is on Win7 Home Premium, PC is on Win7 Professional.
    – tsw_mik
    Commented Jan 22, 2017 at 17:47
  • Have you tried \LaptopUser - e.g. no domain at all? Commented Jan 22, 2017 at 18:45

3 Answers 3

6

Try this Registry Key

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

and set its value to

DWORD(32 bit): LocalAccountTokenFilterPolicy = 1
1
  • This is the ONLY solution that makes my network work they way it has for the last 20+ years (without having to enable lots of firewall rules, or setup shares, or the dozens of other popular answers -- none of which I have ever done nor ever want to do).
    – James L.
    Commented Nov 7, 2022 at 3:06
0

It may have something to do with elevated permissions. Your System Event Log might give you further detail as to what is going on under the hood. The Security Policy MMC snap in should be super helpful in determining/clarifying said permission issues provided your OS is compatible.

-1

In Vista+, administrative shares can only be accessed if the machine is in domain and you're a domain administrator.

  • This can be changed by setting HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System:LocalAccountTokenFilterPolicy to DWORD 1 -- but
  • it's preferable to use the new, more manageable Users share for normal file sharing.
    • Under it, an accessing user will only see profiles and folders in them that the owner chose to share with them (technically, for which they have read&execute permissions).
      • So if you log in as yourself, you don't even need to do anything, you already have access to your entire profile folder
    • The idea is, you place all your personal files under your profile rather than in random places across the disk. It's now okay to do so.
  • Finally, you can replace an administrative share with a normal share:
    • go to the drive's properties, "sharing" tab, unshare it, close the dialog, then reopen it and re-share the drive as a normal share. You need to grant an accessing user permissions at both the "share permissions" tab and for every file/folder you wish to have access to. Be careful here: you certainly don't want J Random Hacker, or a virus, or yourself accidentally to e.g. write to your Windows folder.
3
  • (copied from stackoverflow.com/a/40325060/648265). Commented Jan 24, 2017 at 1:46
  • Thanks, but I don't really want to share the contents of my drive with anyone except for myself when accessing it externally with my normal username and password.
    – tsw_mik
    Commented Jan 24, 2017 at 19:12
  • @tsw_mik disable the guest account (if it's not disabled already) and you're good. By default, only you and local admins (and SYSTEM but it cannot login on the network) have access to your profile. The big idea is, administrative shares are only there for system administration tasks, not for accessing files during normal use. Commented Jan 24, 2017 at 23:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .