0

I have a D-Link off the shelf router, several devices with different OS / platforms are connected via Ethernet cable and WiFi.

My main laptop is a ThinkPad X230 with an Intel Centrino wireless adapter running Windows 10 and Linux Mint on separate partitions. I travel frequently and use many wireless APs, I am able to connect to them just fine using either Windows or Linux.

However, at home I can't see my SSID in the Windows menu, unless I go through these steps

  • Switch router off
  • Switch laptop wireless off (via hardware switch on side of laptop)
  • Switch router on (wait for initialisation process)
  • Switch laptop wireless on
  • Now my SSID will be shown in the Windows Wifi menu and will connect successfully. It will work until I hibernate or switch the laptop off - after this I have to go through the cycle again.

I don't have this issue when I am booted into Linux, it always finds the WLAN when it is in range. There have been no changes or updates to the wireless adapter drivers and I have installed the latest ones from the Lenovo website. I don't have any unusual network settings, its just a consumer grade D-Link router and a standard Windows 10 installation.

How can I diagnose the fault?

  • Just to double-check, is your SSID configured within your router to be hidden by default? – Run5k Jan 22 '17 at 20:23
  • @Run5k Definitely not, I have connected a new device today, and I just checked the settings at 192.168.1.1, also I have had people visit and connect their phones to the WiFi recently. – DizzyFool Jan 22 '17 at 20:51
  • For troubleshooting purposes, you might try to disable the Fast Startup function within Windows 10. On my oldest laptop, it had problems connecting to the Wi-Fi until I made that change within the OS. If that doesn't have any effect, you can easily turn it back on again. – Run5k Jan 22 '17 at 20:58
  • @Run5k This is already disabled to allow dual booting using the GRUB bootloader. – DizzyFool Jan 22 '17 at 20:59
  • Understood. From my perspective, the first things that came to mind were the setting within Windows to "Connect even if the network is not broadcasting" and the Fast Startup function. Hopefully someone else can chime in with a better suggestion. – Run5k Jan 22 '17 at 21:05

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.