0

I have an Asus Eeebook X205T, and I'm trying to boot into a linux live thumb drive so i can install linux on it. I have tried every combination of BIOS settings but it still wont boot.

I have used Rufus and UNetBootIn, and neither of them work.

I have the 32-bit Ubuntu iso (Ubuntu-16.04.1-desktop-i386.iso) I have tried the amd64 version, but nothing works

I can boot into Windows PE perfectly fine. I clean installed Windows 10 a few months ago. But Linux doesn't work.

Here are my BIOS options. I have tried every combination I could think of:

Start Easy Flash
Network Stack Configuration
USB Configuration
      Controller Select: EHCI or XHCI
      Enable EHCI Debug port
Boot (to set boot order)
security (secure boot and BIOS passwords)

I have made sure that the flash drive is the first thing in the boot order, and I have turned off secure boot.

When I hit the boot menu key when I boot up, The menu comes up with 3 options

Windows Boot Manager
UEFI: <USB Drive name>
Enter Setup

When selecting the USB drive, the menu pops up again. After selecting the USB Drive a second time it boots into Windows

I am 98% sure that I have been able to boot into Ubuntu before, It was 2 years ago, but I am sure I booted into Linux Live.

I really would like to install Linux, If you have any questions or help, I would greatly appreciate it.

migrated from stackoverflow.com Jan 22 '17 at 23:26

This question came from our site for professional and enthusiast programmers.

  • Have you tried the USB drive in other computer? It boots ok Linux? – jgorostegui Jan 22 '17 at 23:42
  • @jgorosdev I have. I was able to boot in to the drive using my desktop PC – Aryan Jan 23 '17 at 1:04
  • I would try different things: 1) Update bios to the latest version. 2) Try installing Ubuntu 14.04.5 LTS (32 bit) version (you con download from here). 3) Turn off secure boot and try booting. 4) Disable UEFI in bios and flash ISO in MBR Partition scheme for BIOS (Legacy) and UEFI mode (using Rufus tool) and selecting non-UEFI option at boot. – jgorostegui Jan 23 '17 at 8:16
1

So after a few hours of research, I found that my computer (Asus X205T) uses 32-bit UEFI mode to boot. (https://help.ubuntu.com/community/UEFI):

Ubuntu32bit cannot be easily installed in UEFI mode. This is a problem if 32-bit UEFI is the only way your computer can boot, e.g. if you have a modern Intel Atom based laptop. In this case, you will need a complicated work-around.

Ubuntu does not have that type of ISO available. I have managed to find a work around here: https://github.com/lopaka/instructions/blob/master/ubuntu-14.10-install-asus-x205ta.md

I found only one ISO that natively supports 32-bit UEFI which was Debian Linux.

In Wheezy (Debian 7.0), i386 UEFI support was intentionally omitted for a variety of reasons. However, since then lots more UEFI-only x86 machines were produced so support was added in Jessie (8.0). All the standard i386 Debian installation media should work for UEFI installation as well as in BIOS mode.

Which when I made a bootable flash drive, worked flawlessly.

Hopefully the Ubuntu developers will catch on and make a 32-bit UEFI bootable ISO.

0

Your best bet is to turn off Safe Boot, if you're using UEFI.

Then, through Rufus, create a GPT for UEFI bootable drive based on your ISO. If you're not using UEFI, I'd recommend trying the MBR bootable drive but that's just a guess, I've never actually tried to install Windows 8+ in Legacy mode.

Once you have your drive ready, reboot and from the BIOS, select the UEFI thumb drive.

Hope it works, let me know if it doesn't.

  • I have turned off Safe Boot. Also when I choose GPT for UEFI bootable drive, it gives me an error saying "When using UEFI target type only EFI bootable images are supported ... ". – Aryan Jan 23 '17 at 1:00
  • There's something wrong with your image, check the HASHES provided by Ubuntu but it's most likely corrupt. – Ginnungagap Jan 23 '17 at 6:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.