17

I have tried everything, going to advanced power settings, system settings but nothing. I have also tried to go to Intel options but i don't see any option to turn off power saving so I don't know what to do. It changes when im swapping windows, for example, if I am on Facebook and I swap to a game window, it decreases in brightness.

6
  • I didn't even know brightness can change in a desktop computer. Laptops, sure, but a desktop? – user477799 Jan 23 '17 at 10:19
  • im not using a desktop xD – 맑음Jonnuh Jan 23 '17 at 10:20
  • Your question says "desktop-computer". – user477799 Jan 23 '17 at 10:27
  • 1
    What is the model of your laptop? What do you mean by "brightness change"? Does it changes according to ambient light conditions / battery level? Does it change when you leave your laptop idle for a few minutes? Please add these to your question (don't answer in a comment) to help us understand your issue. – Máté Juhász Jan 23 '17 at 10:37
  • 1
    I have seen this behavior when I am NOT plugged in and using battery power. It reduces brightness when showing dark images (or windows) and increases brightness when showing very light images. But when I am plugged in, the brightness won't change when switching between dark and light images. – Vishnu Haridas Sep 14 '18 at 19:03

10 Answers 10

19

This was bugging me for years till I found answer in some obscure forum, here it the problem: https://support.microsoft.com/en-us/help/3046889/intel-display-power-saving-technology-settings-incorrect-if-power-source-changed-during-sleep

In case the link drops dead, here is still solution how to fix it

Solution:

  • Open your Intel HD

    • The drivers for your integrated Intel HD graphics card. I am aware this is counter intuitive for users who have dedicated graphics card, but the way this whole thing at point of writing is working means that most settings from here are considered 'master' settings.
  • Make sure that under battery you have the power saving option disabled.

    • Yes, I know that you might be thinking what kind of hard liquor I was drinking, but trust me, this setting is still in affect when you plug in your laptop into the wall.
    • Make sure to check this from time to time, because I found out that this options get reactivated on updates and some other random triggers.
  • If you notice that your screen is still flickering brightens based on background, just unplug the power cable and plug it back it. This will reset some DPST settings and it will stop doing it. This happens only if you use sleep on your laptop. Full shutdown should be fine

5
  • oh my god thank you so much. such a simple solution and it worked!! :) thanks – 맑음Jonnuh Jan 23 '17 at 12:11
  • Thanks for the addition, I noticed that it flickers when the windows displayed are changing. Your fix by replugging the power adapter worked. Thanks! – Maarten Kieft Aug 30 '17 at 6:43
  • This was bugging me for over a year... Was so frustrating... Then I bought new laptop (this wasn't the only reason for it) and same thing was happening, I almost lost my sanity there :D – Miroslav Saracevic Aug 30 '17 at 8:46
  • This solved my problem. For me, the screen was using some kind of auto-contrast adjustment, which caused light screens (like web pages) to become much brighter, while dark screens (like many apps with grey backgrounds) would become much darker. – likebike Feb 6 '19 at 4:33
  • The last step saved me some time. I already had done the others but it was still changing the brightness. Thanks @MiroslavSaracevic – Wesley Gonçalves Apr 3 '19 at 14:43
4

The other answers didn't work for me - here's how I fixed it:

  1. From your desktop, click the Intel Graphics Settings icon in the bottom right-hand corner.
  2. Then from the Intel Graphics Settings dashboard, click on the Power icon.
  3. Tick Disable under Display Power Saving Technology.

This is taken from the Reddit source.

1
  • 1
    I find it amusing that reddit source links back to this threads accepted answer as source :D – Miroslav Saracevic Nov 27 '19 at 8:05
3

I believe it's called 'adaptive brightness' and it's under the power settings advanced options.

enter image description here

4
  • i tried that. Its on off and it still changes – 맑음Jonnuh Jan 23 '17 at 11:10
  • You said you've tried looking in the Intel Display settings.. when it asked for basic/ advanced settings did you click basic? I'm sure there are power settings in there? :/ – Charlotte Jan 23 '17 at 11:18
  • there's no advanced settings in power :/ – 맑음Jonnuh Jan 23 '17 at 11:26
  • Windows 10? See the link attached.. I see no reason there wouldn't be? confuuused. s32.postimg.org/hfivk1ulh/… – Charlotte Jan 23 '17 at 12:07
3

Late in the day, but I've just been entertained by this problem. After reviewing quite a few posts, none of which fixed the issue for me, I noticed that -

  1. Right click on desktop, select Graphics Properties
  2. Select Display
  3. Changed Refresh Rate from 40hz to 60hz and Saved the profile

Fixed the issue with Windows 10 contrast issue instantly for me on a Dell M4700 Precision.

Hope this helps folks.

3

Turning off Display Power Savings in Intel® Graphics Command Center fixed the issue for me.

Display Power Savings in Intel® Graphics Command Center

1
  • YES, thank you so much! Nothing else worked. Now there are no more annoying screen brightness changes on battery! – Nicholas Stommel Dec 4 '20 at 4:15
1

What I did was simply go to Display in the Settings application and unticked "Change brightness automatically when lighting changes". It should be on the top of the menu.

1

For Windows Surface users

OR

For those who don't have Intel® Graphics Command Center OR Adaptative brightness in Power Manager, you can download Intel® Graphics Command Center from Microsoft Store (just write Intel Graphics Command).

Open Intel CMD Center you downloaded from MS Store, go to System menu (left panel), then Power and turn off:

  • Adaptative brightness
  • Display Power Saving
  • Enhanced Power Saving
0

I did not have the display power settings option in the Intel® Graphics Command Center on my Dell G3 3590.

What worked for me:

Go into your Bios settings (for my Dell laptop press F12 while booting) > go into video settings and disable the dynamic back light control.

0

I had a similar issue with a Lenovo Thinkpad P1 Gen2 under W10PRro version 2004. Only a few options were available and none for turning on/off the adaptative brightness.

However, turning off the HDR mode seems to solve this issue. Hope this helps.

0

I found out that if you download/already have Intel Graphics Command Centre, you can go into 'System' then from there go into 'power'. And if 'adaptive brightness' is on, turn it off, however, for me it was already turned off, so go down and turn:

  • display power savings: off

Now you shouldn't have that issue where your screen will automatically change brightness when it goes from dark to light images.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.