so I have connected both machines to the same switch. both have internet through ethernet and are in the same network. I am trying to connect to Windows 10 it is not working. So I decided to test using ping and ping gets stuck. Feedbacks are really appreciated. enter image description here

mona@pascal:~$ ping
PING ( 56(84) bytes of data.
  • Did you ensure that your Windows 10 machine is using a Private network profile to allow ICMP traffic? How do I force Windows 10 to see a network as private?
    – Run5k
    Jan 23, 2017 at 18:47
  • 1
    In windows 10, go to Firewall then Advanced Settings. Turn off the Domain Profile, Private profile and public profile and try again. If this works, it is a firewall issue and is usually the case. Can you also list the IP of the ubuntu machine and the IP of the windows machine?
    – Narzard
    Jan 23, 2017 at 18:48
  • They are both in the same private network. Linux machine IP address is
    – Mona Jalal
    Jan 23, 2017 at 18:48
  • Just to check, when you right-click your network icon in the Notification Area and select Open Network and Sharing Center, the windows that appears specifically says that it is a Private network?
    – Run5k
    Jan 23, 2017 at 18:53
  • turned off the Firewall settings @narzard told and it pings now. Can you please write that as an answer? thanks
    – Mona Jalal
    Jan 23, 2017 at 18:54

3 Answers 3


You want to make sure that ICMP for ipv4 is enabled on the inbound rules for your Private Network Firewall profile.

  1. Open Windows Firewall
  2. Choose Advanced Settings.
  3. Inbound Rules on the left pane.
  4. Find File and Printer Sharing (Echo Request - ICMPv4-In).
  5. Double click to open the properties and choose the advanced tab and make sure that private is checked.

The asnwer aceppted doesn't work for me. I can't ping from my guest centos 8 vm to my host windows 10. VirtualBox has Bridged Network configured.

Host OS: windows 10 home single language
Version: 1909

Virtualbox 6.1.10:

  • host: windows 10
  • guest: centos 8

There exist 2 entries for File and Printer Sharing (Echo Request - ICMPv4-In)

enter image description here

Changing the first one to Private doesn't work.

Trurn off the firewall does work.


You can also enable firewall rules on the command-line, using netsh. It is quite cumbersome, but can be useful if you need to do it on several machines or often.

Many useful rules are already pre-configured in the firewall, but not enabled by default.

To enable ping only, you can enable the "Core Networking Diagnostics" group of rules:

netsh advfirewall firewall set rule group="Core Networking Diagnostics" new enable=yes

To enable "File and Printer Sharing" there is a group of rules named just that, so :

netsh advfirewall firewall set rule group="File and Printer Sharing" new enable=yes

To list all inbound rules into a "my_firewall_rules.txt" file in your user directory :

netsh advfirewall firewall show rule name=all dir=in > $HOME\my_firewall_rules.txt

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.