1

I have two computers, both running Windows 10 Pro (Anniv Edition). On one computer, OneDrive works just fine. But, on a different one, I can't get logged in to OneDrive.

I can go through the login screen, give it my email and password, then approve the 2-factor authentication. But then it tells me something went wrong (unspecified), but suggests that I go to the task tray and select OneDrive settings and add my account. When I do that (email address, password, 2-factor authentication) I am presented with a new dialog. And yes, my email address is tied to both a personal and a "work/school" account.

Set up OneDrive

The problem is, all of my OneDrive files are attached to my personal account and Personal is grayed out and unclickable (yeah, I tried anyway).

Any ideas on what it takes to get this setup correctly?

Update and clarification

Just to be clear, this used to work on this computer, but at some point stopped. It's a computer that does not get used much and had not even been turned on for a few months.

A comment by Ramhound got me thinking. I went in to Manage my Account and removed the workstation in case it really wasn't correct anymore for some reason, and now I can't get it back as a trusted device. I have tried a couple of things, namely on the workstation transitioning my account to local account, rebooting, then transitioning it back to my Microsoft Account. While I did indeed was asked for a verification code (2-factor), the workstation has never been re-registered as a trusted device. Some threads say to go to Settings/Accounts/Your Info and click the Verify button, but that appears to no longer exist under Windows 10 Pro (Anniv Edition).

At this point, since there isn't much on this computer, I'm getting "this close" to rebuilding it again from scratch, but there should be a better way.

And yet another update

I have determined that this problem stems from the fact that I don't use this particular computer very much (it sits in my garage, hooked up to a X-Carve CNC that I don't get to use as much as I would wish). In my consideration of rebuilding this computer, I went to another computer that I retired just a few months ago and booted it back up. When it came up I was told that I had to re-enter my OneDrive credentials (which the first computer did too, in hindsight), and now this second computer can no longer get to my OneDrive with the exact same message.

I decided to rebuild this garage computer on the other hardware and, of course, OneDrive works again. I then renamed the "broken" computer so the new computer could take its name, and when I did, My Account recognized this computer again, with the new name, as a trusted device. So hoping that was the fix, I tried OneDrive one more time, and still no love, it will not connect correctly.

  • Is the computer that you can't log into the Personal OneDrive your personal computer, or is it supplied by an institution/company? "it tells me something went wrong (unspecified)," anything related to that error in the Event Logs? – Ƭᴇcʜιᴇ007 Jan 23 '17 at 21:10
  • It's mine. Scratch built. I will look in the event logs this evening. – Jim Jan 23 '17 at 21:23
  • 1
    You need to verify your second PC. Your Microsoft Account doesn't "trust" your second PC until you do that. Settings -> onedrive > verify the percise location might have moved, there will be a link you click, in order to do so. You can also just log into your MS account and do it from there i think. – Ramhound Jan 23 '17 at 23:32
  • @Ƭᴇcʜιᴇ007. Nothing in the event logs. – Jim Jan 24 '17 at 15:22
  • @Ramhound. I have already verified my Live Id when I setup the computer. I double checked just now by logging into the web and looking at my authorized machines, and it is there. – Jim Jan 24 '17 at 15:24
1

The workaround for me is that OneDrive had to be uninstalled and reinstalled first. I was able to contact OneDrive Support, and while I don't yet (and may never have) an explanation as to why this happened, they asked me to try the following (after of course doing everything outlined in this post that I already tried...)

  1. Press the windows key and the letter "r" at the same time to bring the run window up.
  2. Enter %SystemRoot%\SysWOW64\OneDriveSetup.exe /uninstall and press enter
  3. After the system has uninstalled One Drive wait a few minutes before reinstalling.
  4. Go to the "Run" window again and enter %SystemRoot%\SysWOW64\OneDriveSetup.exe
  5. Follow the install instructions but when it asks you if you want to update to the latest version say no.

While that basically worked, I did have to reboot my computer after the install. After it prompted me to upgrade to the latest version (basically said I had to upgrade to continue using OneDrive), and when I said No, it pretty much shutdown OneDrive. But, I rebooted, and then it asked me for my Microsoft Account credentials and it now works. OneDrive hasn't badgered me to upgrade again yet, but I am sure it will, and that will probably be fine at this point as my other workstations are running just fine with the newer OneDrive.

As an FYI, the non-upgraded version is "Version 2015 (Build 17.3.6381.0405)" and the current upgraded version on my other workstations (as of this posting) is "Version 2016 (Build 17.3.6743.1212)".

-1

I had to "Unlink" my PC from the settings and then I was able to sign in again (the personal button turned blue).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.