2

In my home I have an internet connection in the wall (female) from where my internet is provided. A couple of months ago I used a D-link router to spread the internet in the home. Sadly they D-link router died. Anyways I bought a tp-link router and plugged it in and everything was working fine the first week. Then after a week I got different DNS problems.

  • Dns probe finished no internet
  • Dns server not responding

I tried to reset router, change dns settings in Windows to googles (8.8.8.8, 8.8.4.4), flush dns from cmd, change dns server inside of the routers setting, none of which have worked. If I face a dns problem, then rebooting the router, I will have internet acces for around 1h, then the problems will accour again. By experience it seems that when i go to netflix it will often dropp internet access. Like netflix is some kind of "trigger". When I put an ethernet cable directly from the wall to computer, internet works fine. So by my conclusion there is something wrong with the router.

The model number is TL-WR840N/TL-WR840ND

I have tried to explain as best as I can, but I have very low (none) experience in this field.

Edit 1: an answer to Alexs question

From wall to computer Ethernet adapter Ethernet:

  • Connection-specific DNS Suffix . :

  • Link-local IPv6 Address . . . . . : fe80::e568:d749:2132:a65a%6

  • IPv4 Address. . . . . . . . . . . : 192.168.138.23

  • Subnet Mask . . . . . . . . . . . : 255.255.255.0

  • Default Gateway . . . . . . . . . : 192.168.138.1

From wall to router, router to computer Ethernet adapter Ethernet:

  • Connection-specific DNS Suffix . :
  • Link-local IPv6 Address . . . . . : fe80::e568:d749:2132:a65a%6

  • IPv4 Address. . . . . . . . . . . : 192.168.0.102

  • Subnet Mask . . . . . . . . . . . : 255.255.255.0

  • Default Gateway . . . . . . . . . : 192.168.0.1

From wall to router, then wifi Wireless LAN adapter Wi-Fi:

  • Connection-specific DNS Suffix . :
  • Link-local IPv6 Address . . . . . : fe80::cc96:5a79:ea35:7b0%14

  • IPv4 Address. . . . . . . . . . . : 192.168.0.101

  • Subnet Mask . . . . . . . . . . . : 255.255.255.0

  • Default Gateway . . . . . . . . . : 192.168.0.1

Edit 2: I live in a studenthouse who uses something called mikrotik OS http://www.mikrotik.com/ I must every 10h sign in to this "OS" with my room number and some random password.

  • Google's DNS 8.8.8.4 is wrong, correct one 8.8.4.4. When you plug computer directly to the wall, what ip address you get(use ipconfig from cmd to get it) and what IP would be assigned when you connecting via your router? – Alex Jan 23 '17 at 23:12
  • I decided to edit my question for read ability. And yes I agree it is 8.8.4.4, just an error in the original post. @Alex – Olba12 Jan 24 '17 at 19:10
  • Does provider of this 192.168.138.0/24 network allow to use own routers? It could be on their side. Try to change MAC address on WAN side to the same as yours computer(there should be a button that says something - "copy my MAC" similar to this) – Alex Jan 25 '17 at 4:50
  • I dony know actually, I do not want to ask them. But it's not in the roomagreement or house rules. Hmm, I can try to clone the mac adress sure. The weird thing though is that yeasterday night i turned off my computer and started the router. I has now worked for 10 hours, I have been connected with my smartphone the whole time and nothing else. 10 hours is considered a long time, given how it has worked the last days. @Alex – Olba12 Jan 25 '17 at 9:19
  • When I connected my computer to the router, the internet went off 5 minutes after "dns probe finished no internet" in chrome. @Alex – Olba12 Jan 25 '17 at 9:45
1
+100

IMHO the best solution would be to visit IT who managing that mikrotik firewall and ask them to add your router in exclusion list since they doing some kind of HotSpot time base filtering.

You can try one more solution - use your router as access point. Set IP on LAN(!!!) port (router) as 192.168.138.254/255.255.255.0 and disable DHCP then plug your router as LAN port <-> Wall and leave WAN port open.

Just keep in mind that it blindly chosen static IP (192.168.138.254) in hope it wouldn't seat in DHCP range of mikrotik.

0

Ideally you should set your TL-WR840N to bridge/AP mode and your PC's IP settings to DHCP (including DNS servers), this way your PC can pick up the settings assigned by the Miktotik router.

If not, when the Mikrotik Captive Portal kicks in you might not be able to connect to it's web page (for entering the room_no/passwd) as you might be on the wrong IP subnet. That in turn will cut off all internet access for you.

Mikrotik can be setup to restrict your access to remote DNS servers even when you are logged in. This restriction is definitely active when you are in captive portal mode (i.e. you have to enter the password). So ideally your DNS server should be the Mikrotik.

You can see the subnet used by Mikrotik LAN DHCP server by connecting your PC (in DHCP mode) directly to the wall plug and once the internet works run cmd.exe and type ipconfig in the terminal.

Typically Mikrotiks are set to do bandwidth shaping as well i.e. to automatically throttle your speed if you exceed a predefined threshold of downloaded MB/GB in a period of time (like if you download a lot of video). This is to prevent one user hogging up all the bandwidth.

If the Mikrotik is configured correctly it is impossible to bypass its rules and filters even with a spoofed MAC ;)

If all of the above doesn't work then your TL-WR840N is broken.

  • How do I set my PC:s settings to dhcp? Today I have been able to, connect pc via router that is in AP mode. But on phone I cant get pass the log in window. It just refuses to give me access. – Olba12 Jan 31 '17 at 3:02
  • Ok I google it, and both ip/dns is set to automatically in Windows. – Olba12 Jan 31 '17 at 3:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.