0

I have a PC with a Silverstone KL-02 case, a Biostar TZ77XE3 motherboard and a PC Power&Cooling Silencer 470 PSU.

For a long while I've had trouble powering this machine on - I would have to try pressing the power switch several times, or trying different button press durations, before it would actually power up.

Recently there's been a power outage in my neighborhood (while I was away). The power overall is back, and it doesn't look like anything in my apartment burnt out, but - I can't get the PC to power up.

Findings I've made:

  • I've checked my power supply by shortening pins 15 and 16 of the 24-pin connector: The fan is turning and the voltages seem ok when checking with a multi-meter (I only tested a few, not all 24).
  • When I check the resistance I through the case's power switch (via the headers at the end of the blue-white twisted pair) - it's typically infinite, drops to 0 when pressed and climbs quickly to infinity after a depress.
  • I tried using the motherboard's on-board power switch - no effect.
  • I tried using the JCMOS jumper to shorten the two pins usually taken up by the power switch connector - no effect.
  • I don't remember whether the motherboard typically has a light which remains on while power is "off" but the power chord is connected. I think it doesn't (meaning that's not an indication of the board's state).
  • I don't see any capacitors which seem to have blown out. However, the capacitors are covered, and the cross mark I remember from earlier motherboards I owned, where they pop out / blow out does not seem to be exposed. See this image of the board for an illustration of what I mean.
  • No physical damage is apparent anywhere on the board or the PSU.

I suspect the problem is with my motherboard. Is that necessarily the case? If it is, what can I do other than replace it altogether?

  • 5
    Try a different, known-good PSU, if it doesn't work, replace the motherboard. "If it is, what can I do other than replace it altogether?" Tearing apart and fixing a motherboard at the electronics level is off-topic for SU. – Ƭᴇcʜιᴇ007 Jan 23 '17 at 21:15
  • @Ƭᴇcʜιᴇ007: I didn't ask how to tear it apart; but if you're telling me that's the only thing I can do, that's an answer. In fact, your comment does sound like an answer generally. – einpoklum Jan 23 '17 at 22:19
  • Check you motherboard for the presence of bulged capacitors. As you described motherboard's previous behavior, it could be an issue. When you testing, disconnect all other equipment (include extra cards such as video and use internal video card if it present) keep just required minimum to spot wrong part – Alex Jan 23 '17 at 22:53
  • Sounds like an issue with a capacitor to me. I've read about that somewhere: how if a capacitor is going bad it may take several tries to turn on for whatever reason – Blaine Jan 23 '17 at 23:39
0

I personally haven't dealt with a power outage, but have in fact dealt with (what I suspect) a motherboard that suffered electrical static discharge (ESD).

Somewhat following CompTIA's A+ guidelines I did the following, checking from source to destination:

  • Is the electrical grid suffering a brownout/blackout?
  • Is the whole structure's power OK, what works and what is damaged?
  • Is the electrical circuit the device plugged into fine? Is the power outlet/socket grounded/wired correctly?
  • Is the device itself grounded/wired properly?

Internally, diagnose:

  • Does the power supply work? More importantly, does it output the correct current/voltages?
  • If the motherboard has a light, is it lit up or not? Should it be?
  • Have you discharged the system by unplugging it and pressed the power button a few times?
  • Are there any blown capacitors, or other chips damaged visually?

The first section, you can run thought the questions quite quickly. It helps to have a receptacle tester to ensure everything is in order.

The second section as you have done the tests, seems as if it is the motherboard. It is always handy to have a spare PSU laying around, but that isn't always the case.

When I got to the last question in the list, nothing was damaged, the PSU worked, so I was quite surprised. It turns out I had a case where the primary BIOS chip and the backup were damaged.

Replacing the two chips was done by the motherboard manufacturer. This could also be what happened with you, but DIY repair is beyond the scope of Super User.

  • While I'm appreciative of your answer, I've checked done some of what you suggest I should check... but I will add some of the other info. – einpoklum Jan 23 '17 at 23:09
  • @einpoklum My answer was kind of convoluted, but it summary it was chips related to the BIOS/UEFI and couldn't be replaced by anyone but the manufacturer. – dark_st3alth Jan 24 '17 at 1:08
0

After following @Ƭᴇcʜιᴇ007's advice in the comment, I tried powering up using a different PSU I was given. At first - it didn't work! That is, I saw the board's 2-hex-digit status display, and the power light, light up for just a half-second, then turn off. A second power button press did nothing.

But then I though maybe I should start loading things onto the PSU, not just plugging in the main 24-pin board connector. Specifically, I plugged in the CPU connecter. That did the trick - the machine now boots. Some of my dual display adatper issues are acting up again somewhat, but - the machine works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.