9

I lost my beloved Q key a few months back. I changed Q to an extra key on my keyboard, but when I updated to Anniversary (1607), I lost my key, which I have since been unable to change back using KeyTweak and then Sharpkeys. I suspect my registry is being "repaired" when I start my computer. Is there any way I can fix this problem?

2
  • I can confirm the same issue has happened to me. At the risk of turning this into an MS-bashing thread, I am going to be rolling back to Win 8.1 unless someone has another option. I'd prefer to stay on 10, though. – apraetor Mar 6 '17 at 13:15
  • 1
    Are you OK with workaround using the AutoHotKey? AHK macro a::b remaps key A to B. This way you can remap your beloved Q key as before. – miroxlav Apr 18 '17 at 14:04
8
+50

Solution 1: AutoHotkey Remapping

AutoHotkey can be used for Remapping Keys and Buttons. However, consider AutoHotkey's limitation below.

The script Capslock::q would make the Caps Lock behave like Q.

Limitation: AutoHotkey's remapping feature described below is generally not as pure and effective as remapping directly via the Windows registry. For the advantages and disadvantages of each approach, see registry remapping.

Solution 2: Modify Keyboard Layout

Microsoft Keyboard Layout Creator can "modify an existing keyboard layout and build a new layout from it." Since a keyboard layout is handled at a system level, it should be more compatible (than AutoHotkey) with all applications.

Note: Microsoft Keyboard Layout Creator does not specifically support Windows 8, 8.1, or 10. Users have had mixed success applying a new layout (Source: Custom keyboard layout with Windows 10). One user recommended a third-party application Keyboard Layout Manager which creates more compatible layouts.

7
  • 1
    It seems that registry mapping is not possible with windows 10, after restarting none of the changes are retained. – keeg Apr 18 '17 at 20:32
  • @keeg Then, will AutoHotkey work for you? – Steven Apr 18 '17 at 20:46
  • I tried but it just screws up the keys, its like they are pressed in and never release, had to reboot to get rid of it. – keeg Apr 19 '17 at 0:34
  • I have used AutoHotkey for years without issue. If you close AutoHotkey (from the tray icon), behavior should return to normal. – Steven Apr 19 '17 at 20:20
  • I will try it again... – keeg Apr 20 '17 at 18:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.