Notepad++ is latest version v7.3.1. Plugin Manager shows v1.3.5 but says v1.4.3 is available and always wants to update. But when the attempt is made, it fails "Installation of Plugin Manager failed.".

Another SU article Notepad++ Installation Error: Installation of plugin failed has an answer indicating that a reinstall of Plugin Manager corrected this. However, when I go to the "Installed" tab, Plugin Manager isn't even listed. I suspect this may be a symptom of the issue.


Ok, very weird. I've found that after a clean install, upon first running Notepad++, it shows no plugins under [Available], but it shows Plugin Manager under [Installed]. If I then run it as administrator, it will show a list of plugins under [Available] and [Plugin Manager] no longer shows under Installed.


Try running Notepad++ as administrator before attempting the update.

I remember this being an issue in some earlier verions, too.

| improve this answer | |
  • Tried that. It exhibits the same behavior: Displays the error when attempting the update and Plugin Manager does not display under the "Installed" tab. – IronRod Jan 25 '17 at 23:42
  • have you tried reinstalling notepad++? – farosch Jan 26 '17 at 6:05
  • Yes, uninstalled/reinstalled twice. I'm going to try an uninstall, clean registry, install and see if that makes any difference. I really think that the key is that Plugin Manager does not show as installed. – IronRod Jan 26 '17 at 15:47
  • I uninstalled, cleaned registry, reinstalled. No difference. I then uninstalled and tried running the non-install version (ZIP). This runs and I see Plugin Manager listed in the "Install" tab. This is on an old Windows 2003 server so I'm beginning to wonder if there is some issue with that OS. Now to figure out how to get the other plugins since none are listed. – IronRod Jan 26 '17 at 16:09
  • But it is also showing no plugins listed on the Available tab even though they are listed in the ./plugins folder. Hmmm... – IronRod Jan 26 '17 at 16:14

As per this similar Super User question:

Try manually downloading the pluginmanager.dll and copy it to your Notepad++ plugins folder.

| improve this answer | |

Control panel -> Internet options -> Advanced Scroll down to Security. Make sure TLS 1.0, TLS 1.1, and TLS 1.2 are all checked.

Good luck!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.