2

I'm using prezto with iTerm and in my .zshrc, I have the following line that changes the color scheme:

sh ~/.vim/plugins/gruvbox/gruvbox_256palette_osx.sh

However, sometimes when I click ⌘ + R, I lose the color scheme and I have to execute the command manually. So I was wondering if it was possible to do it automatically.

I've tried putting it into my profile command:

zsh --login && sh ~/.vim/plugins/gruvbox/gruvbox_256palette_osx.sh

However, when I open a new tab of iTerm, I get the error message:

A session ended very soon after starting. Check that the command in profile "Chin" is correct.

0

Send text at start: field in Settings/General in your iTerm profile.

enter image description here

start it like this:

source "$HOME/.vim/plugins/gruvbox/gruvbox_256palette_osx.sh"

To resolve the "⌘ + r" issue:

Open up preferences (iTerm > Preferences -or- ⌘,)

Under Keys:

  • Under "Key Mappings", add the following, all of which should have an action of ignore:

⌘t, ⌘r, ⌘w

  • It's works on a new tab / window. However, it doesn't solve the issue of ⌘ + R – Chin Leung Feb 3 '17 at 2:10
  • @chin Leung, is ⌘ + R mapped to a custom function on your mac or terminal? – DeerSpotter Feb 3 '17 at 16:25
  • No it's not in the mapping and I don't want to ignore my ⌘ + R. I need it to remap the screen sometimes. – Chin Leung Feb 4 '17 at 17:32
  • @ChinLeung ill have to play with it more, but it does seem like most people run into your issue. Could you use another command to remap the screen instead? Could you do a simple test to see if screen remapping causes this issue, not the hotkey combination? – DeerSpotter Feb 6 '17 at 13:37
  • Hmm, you want me to remap the command to what? – Chin Leung Feb 6 '17 at 18:12

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.