16

Since Windows 7, there's an option to "Peek" at the desktop (overlayed by outlines of opened Windows) when you hover over a thumbnail produced by a Taskbar icon.

On a Windows 10 device, i need to disable this as it is often used in Extended Desktop mode for projecting/displaying content to the public on a second display. While in control using the primary monitor, when trying to switch windows it will often also peek the desktop on the secondary displays, which is not ideal.

Now, I've managed to disable this on a device in the past, but i now cannot find how.

Just to be clear, this is the only function of Aero Peek that i want to disable. I want to keep the taskbar thumbnails, and the option to desktop peek when hovering over the little button on the bottom right (far right of the taskbar).

Can anyone point me in the right direction?

3
  • Feature is actually called Taskbar Thumbnail Preview: sevenforums.com/tutorials/… don't have a device to submit a proper answer
    – Ramhound
    Jan 25, 2017 at 23:04
  • @Ramhound, i dont want to disable Taskbar Thumbnail Preview though. I want to keep the thumbnails, but i want to disable the fact that when you hover on the thumbnails, you can "peek" onto the desktop
    – Salem874
    Jan 26, 2017 at 20:36
  • "On a Windows 10 device, i need to disable this as it is often used in Extended Desktop mode for projecting/displaying content to the public on a second display." - This is the question you asked. The current answer you received does exactly that. Might not be the way you want it to be disabled, but how you want it, isn't an option.
    – Ramhound
    Jan 26, 2017 at 22:05

3 Answers 3

27

I believe I remember seeing that under the Performance Options.

Go to System --> Advanced System Settings --> Advanced tab --> Settings --> Visual Effects --> and uncheck Enable Peek

Disable Peek

6
  • Thanks. This disabled peek entirely though? Is it not possible to only disable it when hovering over the taskbar thumbnail preview? I'm pretty sure i got this working previously?
    – Salem874
    Jan 26, 2017 at 20:40
  • @Salem874 - I doubt it.
    – Ramhound
    Jan 26, 2017 at 22:05
  • 6
    I did not work for me.
    – Jeffz
    Dec 30, 2017 at 21:37
  • 7
    It doesn't work for me in latest windows 10, april 2018 Oct 22, 2018 at 7:08
  • For the records, that toggle sets DWORD EnableAeroPeek in HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\DWM.
    – mirh
    Apr 9, 2021 at 23:02
1

I had the same problem with a projected secondary display. The following procedure prevents the secondary display disappearing when hovering over the Show desktop button.

1) Right-click on the taskbar, select "Taskbar Settings".

2) In the Taskbar section the 5th switch down is labelled "Use Peek to preview the desktop when you move your mouse to the Show desktop button at the end of the taskbar." Switch this off.

3) In the Multiple Displays section, the first switch is labelled "Show taskbar on all displays". Switch this off.

Desktop peek now requires a click on the button, so is still available but not nearly so prone to accidental activation. Additionally, the secondary display is undisturbed even if the Desktop peek is activated/de-activated by a click.

Edit: Updated for Win 10 from https://www.askvg.com/how-to-disable-aeropeek-in-windows-7/

Edit2: Further expanded to prevent taskbar showing on secondary display.

4
  • Why is step 3 required?
    – AnnanFay
    Mar 12, 2018 at 18:02
  • Just for completeness. I don't want the taskbar jumping up on the secondary display.
    – Terry1951
    Mar 13, 2018 at 20:27
  • @Terry1951: Just a suggestion, but avoid naming the option as the "5th switch down". Microsoft are liable to change options (including their order) at any time. Just name the option.
    – AlainD
    Nov 22, 2018 at 16:50
  • @Terry1951, this kind of does what i want, except i'd like this to apply, only only to the "Show Desktop Button" but also to pointing on the preview of a window in the taskbar. I'm almost certain this was possible before, although it may have been with a registry tweak..?
    – Salem874
    Jul 10, 2019 at 17:02
0

You can disable thumbnails previews completely with Winaero Tweaker.

Desktop and Taskbar -> Taskbar Thumbnails and there tick Disable thumbnails completely. Restart Explorer.

2
  • The thumbnails are fine, its the fact that when you hover on them to switch windows (especially multiple instances in the taskbar of the same application are grouped together) that the desktop "peeks" through
    – Salem874
    Jul 9, 2020 at 20:30
  • Well, you can get that behavior with DisplayFusion's custom taskbars .
    – elig
    Jul 13, 2020 at 5:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.