0

My Logitech G500 randomly disconnects and reconnects for some time now, I think it may be related to some Windows 7 update, but not sure. I'm aware this question has been asked some other times before, but none of the answers I saw helped me.

I tried it in another computer and this error doesn't happen, so I don't think it's hardware related. I've also seen that it could be related to "Allow the computer to turn off this device to save power" option in the device properties, but unfortunately, I don't have the power management tab when it comes to the devices related to the mouse (composite usb device + human interface device *2).

Also tried uninstalling them, and reinstalling when restarting, to see if there was some corruption in the windows Registry, but it seems that everything installed is required, and the problem keeps happening.

  • If you suspect a recent Windows 7 update, start removing the most recent updates, that have been installed since the problem started. You don't have that power setting because you don't have a device that requires it. – Ramhound Jan 26 '17 at 15:36
1

I think you have a faulty cable . try to fix it . that's the root cause 8 times out of 10. try also to bend the cable when connected. If it's not a faulty cable it may be a faulty chip on your mouse try another one.

  • I concur. I only just resolved this same issue myself. The cable seemed just fine and I could not reproduce the problem at will. I did all the due-diligence with software and power settings, and even dropped in a spare USB 2.0 pci card. To no avail. Replacing it with a new mouse fixed it. – Yorik Jan 26 '17 at 17:35
  • I've also tried the mouse in another computer and it worked fine, so it doesn't seem to be the problem either – Dane411 Jan 26 '17 at 19:23
  • @Dane411 If so it may be a software problem if everything was working before try this fix from microsoft link – steveen zoleko Jan 27 '17 at 7:45
  • @steveenzoleko It says that update cannot be applied :( – Dane411 Jan 27 '17 at 15:32
  • 1
    @Dane411 have you tried already disabling "usb selective suspend setting" in advanced power options located in control panel then power options ? – steveen zoleko Jan 27 '17 at 18:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.