0

I'm running Xfce on Debian. The menu labels in many windows look crowded and some dialogue controls are missing. The work-around I have found (I cannot remember how) is to prefix a application's start-up command with

GTK_THEME=/usr/share/themes/Xfce-4.6/gtk-3.0/gtk.css

For example, let's say I would like to adjust the volume. In the top-right of the desktop, next to the clock is an icon that looks like a speaker.

Click on that icon and a menu drops down. Move the mouse pointer up and down over the menu items and already something looks peculiar. Each menu-item has to the left of it (ie, between the left-most edge of the menu and the left-most letter in the menu-item's label) some grey space. You might say the menu items are indented. Hover the mouse pointer over a menu-item and that grey space to the left it becomes . . . brighter.

Click on one of the menu-items, Audio mixer...

A window opens, all grey with Volume Control in the title bar. This window, too, looks odd. Starting from the left, across the top, are a string of letters

PlaybackRecordingOutput DevicesInput DevicesConfiguration

Lower down, seemingly floating in space, the word Advanced. Hover your mouse pointer over the word Advanced and its background becomes brighter. Click on it and a row of words appears below.

See the problem? I didn't at first.

Now apply the work-around.

Close the window by clicking the X at the far-right end of the title bar, open a command prompt and enter

GTK_THEME=/usr/share/themes/Xfce-4.6/gtk-3.0/gtk.css pavucontrol

A window opens, the same size as the other and also with Volume Control in the title bar. But this not grey. It's almost entirely white. Across the top is not a string letters but a row of tabs the labels of which are separated by significant amount of space.

Playback   Recording   Output Devices   Input Devices   Confiugration

The word Advanced is there as before, but now with a little triangle to the left of it, pointing at it. Click on the word and the triangle turns and points downwards.

So instead of clicking on the volume icon, I must instead always use this GTK_THEME command.

GTK_THEME=/usr/share/themes/Xfce-4.6/gtk-3.0/gtk.css pavucontrol

I have tried changing the style. Ie, Applications in the top-left of the desktop > Settings > Settings Manager > Appearance.

A window with four tabs opens: Style, Icons, Fonts, Settings, I've tried all the different styles. Each gives me different colours in the title bars and the like. None renders the menu- or tab-labels properly as does the GTK_THEME command.

Another example is vinagre. I am left to do a lot of guessing as to where to click if I run just

vinagre

or open it from Applications > Internet > Remote Desktop Viewer

but if I run it with

GTK_THEME=/usr/share/themes/Xfce-4.6/gtk-3.0/gtk.css vinagre

all kinds of hitherto invisible buttons appear.

Upon exiting, though, I notice in the command prompt a bunch of innocuous warnings such as

(vinagre:6118): Gtk-WARNING **: Theme parsing error: :6:27: The style property GtkWidget:focus-padding is deprecated and shouldn't be used anymore. It will be removed in a future version

or

(vinagre:6118): Gtk-WARNING **: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node box owner ViewAutoDrawer)

have appeared in the command prompt window.

I have read at //wiki.xfce.org/howto/install_new_themes that, for "GTK+ interfaces" (perhaps pavucontrol is a GTK+ interface), can can "Extract the theme in ~/.local/share/themes" I don't have a themes directory in my ~/.local/share directory . . . is that not part of a standard Xfce installation?

Is there a way that I can specify that call programs should be run with

GTK_THEME=/usr/share/themes/Xfce-4.6/gtk-3.0/gtk.css

without having to install a new theme ?

Opening the Applications menu from the top-left corner of the desktop and selecting About Xfce reveals that I'm using version 4.12 of Xfce.

0

Found this forum discussion https://forum.xfce.org/viewtopic.php?id=6263 where mmassonnet suggested on 2011-09-03:

install Greybird, it has support for GTK2 and GTK3 theming. http://shimmerproject.org/project/greybird/

So I opened up Synaptic.

$ su - root
# GTK_THEME=/usr/share/themes/Xfce-4.6/gtk-3.0/gtk.css synaptic

therein searched for greybird and found and installed (along with all dependencies) a package named greybird-gtk-theme.

Once that was installed, I went back to Applications (in the top-left corner of the desktop) > Settings > Settings Manager > Appearence. On the Style tab, a bunch of new styles including (to name a few): Blackbird, Bluebird, Greybird, Kiwi, MurrinaAqualsh, MurrinaBlau, MurrinaBlu, etc.

I arbitrarily picked MurrinaBlu and closed the Appearance window.

After a few seconds, it looked better. Opening the volume-icon's menu (in the top-right of the desktop), the same list of menu-items appeared. But now to the left of Mute audio output, instead of empty grey space, is a check box. Clicking on Audio mixer... opens a window much like the one I had with

$ GTK_THEME=/usr/share/themes/Xfce-4.6/gtk-3.0/gtk.css pavucontrol

So looks like the problem is solved. Thanks, mmassonnet.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.