1

I changed the default location of "Program Files" and "Program Files (x86)" by editing the Registry:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion]
"ProgramFilesDir"="E:\\ProgramFiles\\64bits"
"CommonFilesDir"="E:\\CommonFiles\\64bits"
"ProgramFilesDir (x86)"="E:\\ProgramFiles\\32bits"
"CommonFilesDir (x86)"="E:\\CommonFiles\\32bits"
"CommonW6432Dir"="E:\\CommonFiles\\64bits"
"ProgramW6432Dir"="E:\\ProgramFiles\\64bits"

For 64-bit apps, it is working fine.

But for 32-bit apps, this configuration is not working! All apps try to install in "C:\Program Files (x86)", and I need to change this location manually. After installing in "E:\ProgramFiles\32bits" (which exists), the app works fine. These apps are: NVIDIA Driver, VMware Workstation 12, VLC, Steam, Free Download Manager, Partition Wizard.

Why is this Registry change not working? What can I do to fix it?

  • What do you mean by "it is not working"? Do you mean that the programs you've installed are not working, or that when you install a program it is still prompting to install to the original location, or something else? – music2myear Jan 26 '17 at 19:46
  • sorry, I clarified the question. "...All apps try to install in "c:\Program Files (x86)", and I need to change this location manually..." – apagando_tudo Jan 26 '17 at 19:50
6

When 32-bit programs access certain parts of the Registry, they are subject to WOW64 redirection. For compatibility purposes, they get a different view of the Registry than what's actually there. Therefore, installer programs that are 32-bit don't see your changes.

You need to also change the values in this path:

HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion

Then 32-bit applications will see and use the settings you choose.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.