4

I've tried all the steps in other posts and still no luck. I have UAC set to never, I'm logged in as admin, policy UAC: admin approval mode for admins is set to enable.

I know calc.exe is a huge security risk but is there anyway to run it without UAC?

11
  • Calc shouldn't require Admin permissions or a UAC approval to open. You sure your Calc.exe is legitimate? Jan 26 '17 at 21:07
  • How is using the built in calculator (calc.exe) a huge security risk? Jan 26 '17 at 21:10
  • I have noticed that there are similar restrictions on the built-in Administrator account on a Windows 10 machine. For example, you can't open the default Photos app with the Administrator account. That being said, it is typically a security best-practice to avoid using the built-in Administrator account, leaving it disabled and creating additional admin-level local accounts instead. Is there a compelling reason why you need to use the Administrator account?
    – Run5k
    Jan 26 '17 at 21:48
  • Windows 10 Built-in Administrator account is unable to open ANY Metro Apps. And unfortunately in Windows 10 Calculator is a Metro App.
    – Darius
    Jan 26 '17 at 21:59
  • 1
    @JoshCampbell Sarcasm :) Jan 26 '17 at 22:53
4

Here is an excellent article that helps explain the problem:

Why the built-in administrator account can’t open Edge (and a lesson in UAC).

Ultimately, the author emphasizes the following:

The built-in administrator account essentially runs with all UAC settings disabled. ... By default, the built-in administrator cannot execute modern apps.

As a result, your built-in Administrator account will see messages like the following:

Edge Error Message

The author goes on to explain that you should be able to mitigate this problem by navigating to the following Group Policy location:

Computer Configuration > Policies > Windows Settings > Security > Security Options

Then, enable the following policy:

User Account Control: Admin Approval Mode for the Built-in Administrator account

If this isn't the built-in Administrator account and merely a locally created admin account experiencing the same issues, you may have inadvertently disabled UAC entirely. Once again, quoting the article:

Actually, if you completely disable UAC, no one will be able to run these colorful toy applications. Note that you can’t completely disable UAC through the Control Panel. With the setting Never notify, UAC is still active.

To turn off all UAC settings, you have to disable the security policy User Account Control: Run all administrators in Admin Approval Mode (Computer Configuration > Policies > Windows Settings > Security > Security Options).

If that happened through either a Group Policy or registry change, you should be able to reverse that rather easily to restore access to the modern apps.

4
  • I've tried these and still get the same message. Jan 26 '17 at 22:53
  • I just updated this answer with additional text from the referenced article that explains how this could potentially be happening to a locally created admin account.
    – Run5k
    Jan 27 '17 at 0:21
  • that did the trick! I must have disabled that setting while going through articles. Thanks again for all your help! Jan 27 '17 at 0:39
  • 1
    With the countless number of Group Policies and registry options at our disposal, that type of thing can happen to the best of us. It is good to hear that your account is back to normal, and I'm always glad to help!
    – Run5k
    Jan 27 '17 at 0:42
0

I do not see this mentioned here but this was the actual fix for my MS Windows 10 enterprise "Calculator cannot be opened using the built-in administrator account". I have been fighting this for weeks, trying everything I have read on the internet without any solution. The final fix was so simple. logged into the admin account, went to uac settings, changed it to the highest level, tested calculator, of coarse it did not work and came up with the same error, then I went back into the uac settings and set it to the lowest setting, tested calculator and it still did not work, but it is not supposed to in the administrator account. I rebooted the computer and logged back into the administrator account (accidentally), then logged out and logged into my account which is also an administrator account, I tested calculator and it works now. I hope this helps somebody, I was so frustrated. My main reason for wanting to change this setting is that I have an HP envy 4520 printer that never completes the software setting. it was freezing when it would try and start the web browser. I tried it in a non admin account and it would complete the setup but would not setup the correct drivers because the drivers were locked from it not being an admin account. Now I am off to try and install the printer again now that the uac problem has been fixed.

A quick note: Something about being in the actual administrator account and changing the UAC setting from low to high saving the setting, then changing it from high to low seems to fix the broken UAC. The actual changes will not work until the system is rebooted, and not just logged off.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.