0

My Mainboard is an ASUS P7H55M-PRO. When powered it starts, showing BIOS logo and detecting the components mounted on (See Image 1). On pressing some buttons for starting one of the options of the BIOS menu it won't load anything, remaining stuck on BIOS menu (See Image 2).

IMG:
Image 1

IMG:
Image 2

So the problem is that I c an't start anything, BIOS config nor boot menu nor ASUS EZ flash utility.

What I tried:

  • changed PSU
  • changed RAM, both slot and module
  • cleared CMOS memory
  • flashing another BIOS ROM, (with success), following this guide
  • booting the pc both with an internal and an external video card
  • booting the pc with or without an hard disk
  • booting the pc with or without a bootable USB drive

Now, I don't know what can I try to start BIOS config or boot a OS. I don't know either what could be broken, and I'd like to understand what it is in that case.

Notes:

  • I don't know the history of this mb, I mean, I don't know what they did before it was given to me for repairing it
  • I tried clearing CMOS with and without the battery
  • That looks like motherboard blocked by computrace that was previously activated – Alex Jan 27 '17 at 11:07
  • @Alex ty for your reply. I don't clearly understand where this protection is installed. Reflashing the EEPROM where BIOS is installed should've had erased computrace, isn't it? – Geronimo Grande Jan 27 '17 at 11:22
  • Which BIOS options are you referring to? So you did hit Alt+F2? If so, did you insert a USB stick with a BIOS image as mentioned on the ASUS support website? – Seth Jan 27 '17 at 11:28
  • @Seth I tried with 1604, 1709 and 1330 ROMs flashing them with flashrom. EZ utility won't start in every way, it remains stuck on that screen. Also tried following all the instructions indicated by ASUS – Geronimo Grande Jan 27 '17 at 11:32
  • And there isn't anything that happens if you hit any of the other common buttons to enter the BIOS (F2, Del) and nothing if you choose the other option (F8)? What other BIOS ROM did you use? – Seth Jan 27 '17 at 11:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.