3

I have a remote filesystem which I mount on my Mac (10.11) with the following command:

sudo sshfs username@xxx.xxx.xxx.xxx:/ ~/mnt/remotefs

Sometimes this command works just fine, and it prompts me for a password and the filesystem is mounted. But other times, it just fails with a cryptic Bad address error. I'm not sure what's causing the failures - there's apparently no verbose option for sshfs, so I'm not sure how else I can figure out what's going on. ssh-ing in always works though, so it's not an availability issue.

  • What is the whole error you can see? – Jakuje Jan 28 '17 at 12:07
  • @Jakuje - that's the problem, that's the entire error message. sshfs doesn't have verbose mode. – 3cheesewheel Jan 30 '17 at 8:55
  • Does not have? -o sshfs_debug print some debugging information – Jakuje Jan 30 '17 at 8:58
  • @Jakuje oh, I totally missed that in the man page, I was only searching for 'verbose'. I'll try that! – 3cheesewheel Jan 30 '17 at 9:00
  • I tried added the sshfs_debug option, but now all it does it print the version. It still gives me just the Bad Address error message with no further information. – 3cheesewheel Mar 3 '17 at 12:09
3

You are not specifying the mounting address (where to mount on the host machine). Do it like this

sudo sshfs username@xxx.xxx.xxx.xxx:/ ~/mnt/remotefs . 

to mount it on the current directory. Note the . at the end to represent the fact that we want to mount on the current directory.

| improve this answer | |
  • I don't know how this was an answer to the OP question, however it was the answer to my problem which brought me here. – James Robinson Nov 9 '17 at 17:01
0

in case it helps someone else, I just made sure the local folder existed. for some crazy reason, something like "/Users/usernamehere/MT-owner/backup" would not work.

changed to "~/mt-backup" (making sure folder was created beforehand with mkdir -p ~/mt-backup) and it worked.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.