1

When trying to connect to my Office 365 account I keep getting the traditional Outlook login prompt.

Outlook fails to validate Office 365 account

When running the Test E-Mail Autoconfiguration tool it seems as if IMAP and SMTP only are available, and not Exchange RPC.

Is there anywhere in Office 365 where I can enable/disable Exchange RPC? Or perhaps there is an autodiscover issue?

enter image description here

UPDATE 1:

I ran the two Outlook MS Connection Analyzer tests for Office 365.

The first Outlook Connectivity test fails with this result:

enter image description here

It appears I have a problem with my Autodiscovery and the HTTPS/SSL connection:

enter image description here

2
  • 1
    Which outlook version did you used to connect to Exchange Online? Is that Office 365 and is that up to date? Can you update your posting with an anonymized result from the MS connection analyzer here (AutoDiscovery)?
    – BastianW
    Jan 27, 2017 at 21:48
  • Thank you @BastianW. I'm running Outlook 2016 (all updates applied). Please see update above. Jan 28, 2017 at 7:27

2 Answers 2

1

Just for clarity, don't look for RPC over HTTP. Outlook 2016 and Office 365 use MAPI over HTTP.

Your connectivity tests are very different. The first one resolves only to your local Exchange server, while the second one is going to your server and then redirecting to Office 365 properly.

This is odd behavior since in both cases if the request reaches Exchange it should know your mailbox is located on Office 365 and redirect you to the new autodiscover endpoint (you can see it happen in your second test). The only way I can see two different results happening like that is if there is a load balancer involved and you have a misconfiguration somewhere.

0

After a couple of days' back-and-forth with Microsoft Support we were able to detect the problem using the Outlook Diagnostics Tool.

I had to create/change a couple of my registry settings as described here.

Thanks for all the help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.