15

I've installed a fresh Windows 10 in a partition on my system, enabling bitlocker. Then I booted Linux from the other partition and overwrote the master boot record with Grub so I could boot Linux and Windows. I also removed an unused NTFS partition, hoping to use it as a shared space between Windows and Linux (don't do it -- Bitlocker needs a NTFS System partition to store the unencrypted boot sector, much like a /boot directory on Linux).

However, upon restart Windows complained that "something had changed" on my system and asked me for the BitLocker recovery key. As this kept happening I disabled bitlocker with the idea of re-enabling it later, hoping it would reset itself.

Bitlocker's error was:

"An Error Occurred The System cannot find the file specified".

I've tried re-creating the NTFS partition, but it failed to boot. I fixed the boot process by starting from a Windows installer from USB and using bootrec, the restarting again and using the 'fix the startup' option. However Bitlocker still refused to start. This is related to the error

"The bitlocker Drive Preparation Tool could not find a target system drive. You may need to manually prepare your drive for BitLocker."

There is an interesting description of the process here with a helpful graph

25

The solution turned out to be very simple:

  1. Open an elevated command prompt (search, cmd, right click and 'Run as administrator')
  2. Go to C:\Windows\System32\Recovery\
  3. Rename the file ReAgent.xml:

    ren ReAgent.xml ReAgent.old
    
  4. Start Bitlocker

I've spotted the file here but all solutions listed are more complicated.

| improve this answer | |
  • 2
    Worked for me too. My issue started when I tried to re-enable BitLocker after I converted my partitions from MBR to GPT - using MBR2GPT, which complained about ReAgent.xml as well. – Jonathan Jul 2 '19 at 10:18
  • The fields in the new ReAgent.xml all seem to have been blanked (id/offset/state 0, guid {000...}, path ""), but that seems to be good enough for BitLocker... – mwfearnley Jan 30 at 11:03

Not the answer you're looking for? Browse other questions tagged or ask your own question.